summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/moldy')
-rw-r--r--sci-chemistry/moldy/ChangeLog38
-rw-r--r--sci-chemistry/moldy/Manifest4
-rw-r--r--sci-chemistry/moldy/files/digest-moldy-2.16e1
-rw-r--r--sci-chemistry/moldy/metadata.xml9
-rw-r--r--sci-chemistry/moldy/moldy-2.16e.ebuild57
5 files changed, 109 insertions, 0 deletions
diff --git a/sci-chemistry/moldy/ChangeLog b/sci-chemistry/moldy/ChangeLog
new file mode 100644
index 000000000000..aa66b944195d
--- /dev/null
+++ b/sci-chemistry/moldy/ChangeLog
@@ -0,0 +1,38 @@
+# ChangeLog for app-sci/moldy
+# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/moldy/ChangeLog,v 1.1 2004/12/24 16:47:56 ribosome Exp $
+
+*moldy-2.16e (24 Dec 2004)
+
+ 24 Dec 2004; Olivier Fisette <ribosome@gentoo.org> +metadata.xml,
+ +moldy-2.16e.ebuild:
+ Moved from app-sci/moldy to sci-chemistry/moldy.
+
+ 07 Dec 2004; <gongloo@gentoo.org> moldy-2.16e.ebuild:
+ Added ~ppc-macos
+
+ 01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> moldy-2.16e.ebuild:
+ virtual/glibc -> virtual/libc
+
+ 18 May 2004; Mamoru KOMACHI <usata@gentoo.org> moldy-2.16e.ebuild:
+ Changed app-text/tetex to virutal/tetex.
+
+ 30 Mar 2004; Donnie Berkholz <spyderous@gentoo.org>; moldy-2.16e.ebuild:
+ Change x11-base/xfree dependency to virtual/x11.
+
+ 27 Oct 2003; Patrick Kursawe <phosphan@gentoo.org> moldy-2.16e.ebuild:
+ Fixing sandbox issue from bug 20657
+
+ 04 Oct 2003; Donnie Berkholz <spyderous@gentoo.org>; moldy-2.16e.ebuild:
+ Adding what appears to be a non-optional tetex dependency. However there are
+ sandbox issues at present (bug #20657).
+
+*moldy-2.16e (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/sci-chemistry/moldy/Manifest b/sci-chemistry/moldy/Manifest
new file mode 100644
index 000000000000..2047da81326e
--- /dev/null
+++ b/sci-chemistry/moldy/Manifest
@@ -0,0 +1,4 @@
+MD5 d9349a77920af70d9547f0401fd37037 ChangeLog 1395
+MD5 af1bfbb0777267a03e889b08173f2757 metadata.xml 248
+MD5 c9b35edd4f6155c3a3badcd10a04f89d moldy-2.16e.ebuild 1674
+MD5 073b906dd873064f8f0f5bab474fda43 files/digest-moldy-2.16e 63
diff --git a/sci-chemistry/moldy/files/digest-moldy-2.16e b/sci-chemistry/moldy/files/digest-moldy-2.16e
new file mode 100644
index 000000000000..e048f7b14413
--- /dev/null
+++ b/sci-chemistry/moldy/files/digest-moldy-2.16e
@@ -0,0 +1 @@
+MD5 8a062795aaf531adcfbdb030c87b9ff1 moldy-2.16e.tar.gz 488410
diff --git a/sci-chemistry/moldy/metadata.xml b/sci-chemistry/moldy/metadata.xml
new file mode 100644
index 000000000000..211b8bd0f0a4
--- /dev/null
+++ b/sci-chemistry/moldy/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+<email>spyderous@gentoo.org</email>
+<name>Donnie Berkholz</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/moldy/moldy-2.16e.ebuild b/sci-chemistry/moldy/moldy-2.16e.ebuild
new file mode 100644
index 000000000000..b919fba33f6b
--- /dev/null
+++ b/sci-chemistry/moldy/moldy-2.16e.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/moldy/moldy-2.16e.ebuild,v 1.1 2004/12/24 16:47:56 ribosome Exp $
+
+IUSE="X"
+
+S=${WORKDIR}
+DESCRIPTION="Program for performing molecular dynamics simulations."
+SRC_URI="ftp://ftp.earth.ox.ac.uk/pub/${P}.tar.gz"
+#For lack of a better homepage
+HOMEPAGE="http://sal.kachinatech.com/Z/2/MOLDY.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc-macos"
+
+DEPEND="virtual/libc
+ virtual/tetex
+ X? ( virtual/x11 )"
+
+addwrite /var/cache/fonts
+
+src_compile() {
+ local myconf
+
+ myconf=`use_with X`
+
+#Individuals may want to edit the OPT* variables below.
+#From the READ.ME:
+#You may need to "hand-tune" compiler or optimization options,
+#which may be specified by setting the OPT and OPT2 environment
+#variables. OPT2 is used to compile only the most performance-critical
+#modules and usually will select a very high level of optimization.
+#It should be safe to select an optimization which means "treat all
+#function arguments as restricted pointers which are not aliased to
+#any other object". OPT is used for less preformance-critical modules
+#and may be set to a lower level of optimization than OPT2.
+
+ OPT=${CFLAGS} OPT2=${CFLAGS} \
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ emake || die
+ make moldy.pdf || die
+}
+
+src_install() {
+ dodir /usr/bin
+ make prefix=${D}/usr install || die
+ rm Makefile.in configure.in config.h.in
+ insinto /usr/share/${PN}/examples/
+ doins *.in *.out control.*
+ dodoc BENCHMARK COPYING READ.ME RELNOTES
+ insinto /usr/share/doc/${P}/pdf
+ newins moldy.pdf moldy-manual.pdf
+}