summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/klu/klu-1.0.1.ebuild')
-rw-r--r--sci-libs/klu/klu-1.0.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/klu/klu-1.0.1.ebuild b/sci-libs/klu/klu-1.0.1.ebuild
new file mode 100644
index 000000000000..5fc5f82119e9
--- /dev/null
+++ b/sci-libs/klu/klu-1.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/klu/klu-1.0.1.ebuild,v 1.1 2008/02/05 18:42:23 bicatali Exp $
+
+inherit autotools eutils
+
+MY_PN=KLU
+DESCRIPTION="Sparse LU factorization for circuit simulation"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/klu"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+DEPEND="sci-libs/amd
+ sci-libs/btf
+ sci-libs/colamd"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins Doc/*.pdf || die
+ fi
+}