summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libcerf/files/libcerf-1.3-autotools.patch')
-rw-r--r--sci-libs/libcerf/files/libcerf-1.3-autotools.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/sci-libs/libcerf/files/libcerf-1.3-autotools.patch b/sci-libs/libcerf/files/libcerf-1.3-autotools.patch
new file mode 100644
index 000000000000..d074abbbb3e2
--- /dev/null
+++ b/sci-libs/libcerf/files/libcerf-1.3-autotools.patch
@@ -0,0 +1,49 @@
+Send upstream (j.wuttke@fz-juelich.de) 14.07.14
+diff -Naur libcerf-1.3.orig/libcerf.pc.in libcerf-1.3/libcerf.pc.in
+--- libcerf-1.3.orig/libcerf.pc.in 2013-07-17 03:51:59.000000000 -0600
++++ libcerf-1.3/libcerf.pc.in 2014-07-14 11:18:01.646512503 -0600
+@@ -7,4 +7,5 @@
+ Description: Complex error function library
+ Version: @PACKAGE_VERSION@
+ Libs: -L${libdir} -lcerf
++Libs.private: -lm
+ Cflags: -I${includedir}
+diff -Naur libcerf-1.3.orig/man/Makefile.am libcerf-1.3/man/Makefile.am
+--- libcerf-1.3.orig/man/Makefile.am 2013-02-01 02:00:14.000000000 -0700
++++ libcerf-1.3/man/Makefile.am 2014-07-14 11:17:36.266182267 -0600
+@@ -19,9 +19,8 @@
+ # Website:
+ # http://apps.jcns.fz-juelich.de/libcerf
+
+-man_MANS = w_of_z.3 im_w_of_x.3 dawson.3 cdawson.3 cerf.3 cerfc.3 erfcx.3 cerfcx.3 erfi.3 cerfi.3 voigt.3
+-auxdir = $(datadir)/man/html
+-aux_DATA = w_of_z.html voigt.html dawson.html cerf.html erfcx.html erfi.html
++man_MANS = w_of_z.3 im_w_of_x.3 dawson.3 cdawson.3 libcerf-cerf.3 cerfc.3 erfcx.3 cerfcx.3 erfi.3 cerfi.3 voigt.3
++html_DATA = w_of_z.html voigt.html dawson.html cerf.html erfcx.html erfi.html
+
+ w_of_z.3 : w_of_z.pod
+ pod2man -s 3 -c "libcerf manual" $< > $@
+@@ -35,7 +34,7 @@
+ cdawson.3 : dawson.pod
+ pod2man -s 3 -c "libcerf manual" $< > $@
+
+-cerf.3 : cerf.pod
++libcerf-cerf.3 : cerf.pod
+ pod2man -s 3 -c "libcerf manual" $< > $@
+
+ cerfc.3 : cerf.pod
+diff -Naur libcerf-1.3.orig/test/Makefile.am libcerf-1.3/test/Makefile.am
+--- libcerf-1.3.orig/test/Makefile.am 2013-07-17 01:45:37.000000000 -0600
++++ libcerf-1.3/test/Makefile.am 2014-07-14 11:16:00.204932368 -0600
+@@ -20,8 +20,10 @@
+ # http://apps.jcns.fz-juelich.de/libcerf
+
+ AM_CFLAGS += -I$(srcdir)/../lib
+-noinst_PROGRAMS = test_libcerf_1 runvoigt run_w_of_z
++noinst_PROGRAMS = runvoigt run_w_of_z
+ test_libcerf_1_SOURCES = test1.c
+ runvoigt_SOURCES = runvoigt.c
+ run_w_of_z_SOURCES = run_w_of_z.c
+ AM_LDFLAGS = -lm -L../lib -lcerf
++check_PROGRAMS = test_libcerf_1
++TESTS = test_libcerf_1