summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/x86info/x86info-1.23.ebuild')
-rw-r--r--sys-apps/x86info/x86info-1.23.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/x86info/x86info-1.23.ebuild b/sys-apps/x86info/x86info-1.23.ebuild
new file mode 100644
index 000000000000..7553053682a2
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.23.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.23.ebuild,v 1.1 2008/12/29 23:50:35 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
+SRC_URI="http://www.codemonkey.org.uk/projects/x86info/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/1.21-pic.patch
+}
+
+src_compile() {
+ emake x86info CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin x86info || die
+
+ insinto /etc/modules.d
+ newins "${FILESDIR}"/x86info-modules.conf-rc x86info
+
+ dodoc TODO README ChangeLog
+ doman x86info.1
+ insinto /usr/share/doc/${PF}
+ doins -r results
+ prepalldocs
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must be built with the following options"
+ ewarn "set to Y or M"
+ ewarn " Processor type and features ->"
+ ewarn " [*] /dev/cpu/*/msr - Model-specific register support"
+ ewarn " [*] /dev/cpu/*/cpuid - CPU information support"
+}