aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-09-05 12:36:46 +0200
committerDavid Roman <davidroman96@gmail.com>2024-09-05 12:36:46 +0200
commitd851bed6c61f58bae3bda1acd8ab16e8183b620a (patch)
treecf7407ee63df3f34c1be81f2be6098f9986a51cb /dev-embedded
parentdev-embedded/esp-idf-panic-decoder: add 1.2.1 (diff)
downloadguru-d851bed6c61f58bae3bda1acd8ab16e8183b620a.tar.gz
guru-d851bed6c61f58bae3bda1acd8ab16e8183b620a.tar.bz2
guru-d851bed6c61f58bae3bda1acd8ab16e8183b620a.zip
dev-embedded/idf-component-manager: add 2.0.3
Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/idf-component-manager/Manifest1
-rw-r--r--dev-embedded/idf-component-manager/idf-component-manager-2.0.3.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-embedded/idf-component-manager/Manifest b/dev-embedded/idf-component-manager/Manifest
index 60fbf9985..640694c9b 100644
--- a/dev-embedded/idf-component-manager/Manifest
+++ b/dev-embedded/idf-component-manager/Manifest
@@ -1 +1,2 @@
DIST idf-component-manager-1.5.3.gh.tar.gz 321425 BLAKE2B 1c5b1bd1dc50b214b5b9a8d4ae40681fd33118f4d83469d793de152627d2cd2e2497f3a7e771b27a5aac68886d242e2f3d44c69d94f38ce3385d8bec0700190a SHA512 6a8d5c493f5f361c3b02a145685b58862e8e96261cbe3c5436354446f95f5ca5782a9dd7fa5397bc58438166c07aea6bb958348d596f6a604d5044edba0584c0
+DIST idf-component-manager-2.0.3.gh.tar.gz 322831 BLAKE2B 8456e2f4bb3e4b221aba4c946b7f2a980c36a8796e7fd7a53b97c76fd68f1462f92943bfb185d0dea4ae1792fe91f58527812ec5d81a19462e978fb2625bf2b6 SHA512 632bef699b8164b05d6cd5b0cc93cce28a1f8ec86b3fc2f58989f872ac556af3c8f7ea28d4966880ee3bca64ebb1169a819d4e46652e978e8a3bfab38ae52a02
diff --git a/dev-embedded/idf-component-manager/idf-component-manager-2.0.3.ebuild b/dev-embedded/idf-component-manager/idf-component-manager-2.0.3.ebuild
new file mode 100644
index 000000000..a1717e8e9
--- /dev/null
+++ b/dev-embedded/idf-component-manager/idf-component-manager-2.0.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Tool for installing ESP-IDF components"
+HOMEPAGE="https://github.com/espressif/idf-component-manager"
+SRC_URI="https://github.com/espressif/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+RDEPEND="
+ dev-python/cachecontrol[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/jsonref[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/pydantic-settings[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/requests-file[${PYTHON_USEDEP}]
+ dev-python/schema[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+
+# Requires additional files not available in the tarball
+EPYTEST_DESELECT=(
+ tests/test_component_manager.py::test_pack_component_with_examples_errors
+ tests/test_component_manager.py::test_pack_component_with_dest_dir
+)
+
+# network access
+EPYTEST_IGNORE=(
+ tests/test_api_client.py
+ tests/test_prepare_dep_dirs.py
+)
+
+distutils_enable_tests pytest