aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-01-08 03:56:35 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-01-08 03:56:35 +0100
commit35886c614624877a640da5f4cad3ed7ec0f5c474 (patch)
treee9155c1a91b00ffcc9c22893b52ff6106360518e /dev-libs
parentgames-emulation/yuzu: fixup for last commit (diff)
downloadguru-35886c614624877a640da5f4cad3ed7ec0f5c474.tar.gz
guru-35886c614624877a640da5f4cad3ed7ec0f5c474.tar.bz2
guru-35886c614624877a640da5f4cad3ed7ec0f5c474.zip
dev-libs/olm: Version bump 3.2.9
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/olm/Manifest1
-rw-r--r--dev-libs/olm/olm-3.2.9.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/olm/Manifest b/dev-libs/olm/Manifest
index b1e6692eb..0b856038c 100644
--- a/dev-libs/olm/Manifest
+++ b/dev-libs/olm/Manifest
@@ -1 +1,2 @@
DIST olm-3.2.8.tar.bz2 489350 BLAKE2B bf8b31262c15da2cffd5eeb1f426fe60e83dc60b3377191d65b4b4992133f92adfb7d18deb69b075207550b1b32220a1d807f331e58b41839d8aa5330a80bf3d SHA512 2a249b6880ff0c368458c14d6bae3103890f23dceaaf5753d140884185590fd54f1d7bcb8959f43b3b0f5c9302f76e380e6cdfe3340feab7f9fff60362a39303
+DIST olm-3.2.9.tar.bz2 2734794 BLAKE2B 6c5cc89804071f961ebd571dd5d3fac43aa9517fda4e029a0855fc89f4ec46e49b784aa2cfbf8cec8e34b8ef06c5e61f2111ec30fc872f44c90795359892f205 SHA512 c196430054920d78587fc79eed25312d11498594257b9a12057bfb2feaf2abfb7df35854952b4a36bc22a8c62b99b58e55f9434001a00791ca62ca47556957a5
diff --git a/dev-libs/olm/olm-3.2.9.ebuild b/dev-libs/olm/olm-3.2.9.ebuild
new file mode 100644
index 000000000..19d31a4cd
--- /dev/null
+++ b/dev-libs/olm/olm-3.2.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Implementation of the olm and megolm cryptographic ratchets"
+HOMEPAGE="https://gitlab.matrix.org/matrix-org/olm"
+SRC_URI="https://gitlab.matrix.org/matrix-org/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DOLM_TESTS="$(usex test)"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ BUILD_DIR="${BUILD_DIR}/tests" cmake_src_test
+}
+
+src_install() {
+ use doc && DOCS=( README.md docs/{{,meg}olm,signing}.md )
+
+ cmake_src_install
+}