aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2021-04-17 19:38:41 +0200
committerOliver Freyermuth <o.freyermuth@googlemail.com>2021-04-17 19:38:41 +0200
commita48417a2831485278cd96048f9a7820b8349d3a0 (patch)
treeabf0a9287f6eaa0162c29b411112b4e8043c4925 /games-arcade
parentmail-client/mailspring-bin: version bump (diff)
downloadguru-a48417a2831485278cd96048f9a7820b8349d3a0.tar.gz
guru-a48417a2831485278cd96048f9a7820b8349d3a0.tar.bz2
guru-a48417a2831485278cd96048f9a7820b8349d3a0.zip
games-arcade/taisei: Use xdg-utils and update DBs and caches.
This updates xdg-icon-cache, desktop-db and mimeinfo-db, which is needed since an icon, mime info and desktop files with mime info are being installed. Revbump to apply these changes. Closes: https://bugs.gentoo.org/783450 Closes: https://bugs.gentoo.org/783453 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/taisei/taisei-1.3.1-r1.ebuild (renamed from games-arcade/taisei/taisei-1.3.1.ebuild)14
-rw-r--r--games-arcade/taisei/taisei-9999.ebuild14
2 files changed, 26 insertions, 2 deletions
diff --git a/games-arcade/taisei/taisei-1.3.1.ebuild b/games-arcade/taisei/taisei-1.3.1-r1.ebuild
index 26982cbef..381361ff3 100644
--- a/games-arcade/taisei/taisei-1.3.1.ebuild
+++ b/games-arcade/taisei/taisei-1.3.1-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
-inherit meson python-any-r1
+inherit meson python-any-r1 xdg-utils
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -54,3 +54,15 @@ src_configure() {
)
meson_src_configure
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/games-arcade/taisei/taisei-9999.ebuild b/games-arcade/taisei/taisei-9999.ebuild
index 9213c4124..a50bcba07 100644
--- a/games-arcade/taisei/taisei-9999.ebuild
+++ b/games-arcade/taisei/taisei-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
-inherit meson python-any-r1
+inherit meson python-any-r1 xdg-utils
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -55,3 +55,15 @@ src_configure() {
)
meson_src_configure
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}