aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Frei <freijon@pm.me>2022-11-15 20:49:19 +0100
committerJonas Frei <freijon@pm.me>2022-11-15 20:49:32 +0100
commit3d50edb59448e49ca9a1d9e4954df3ee49ce394c (patch)
treeb27d2b64880f89b13a248762659e826dce57f31e /gui-apps
parentnet-client/offpunk: add 1.7, drop 1.5 (diff)
downloadguru-3d50edb59448e49ca9a1d9e4954df3ee49ce394c.tar.gz
guru-3d50edb59448e49ca9a1d9e4954df3ee49ce394c.tar.bz2
guru-3d50edb59448e49ca9a1d9e4954df3ee49ce394c.zip
gui-apps/clipman: new package, add 1.6.1
Signed-off-by: Jonas Frei <freijon@pm.me>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/clipman/Manifest2
-rw-r--r--gui-apps/clipman/clipman-1.6.1.ebuild38
-rw-r--r--gui-apps/clipman/metadata.xml8
3 files changed, 48 insertions, 0 deletions
diff --git a/gui-apps/clipman/Manifest b/gui-apps/clipman/Manifest
new file mode 100644
index 000000000..3d3f27a8c
--- /dev/null
+++ b/gui-apps/clipman/Manifest
@@ -0,0 +1,2 @@
+DIST clipman-1.6.1-deps.tar.xz 724108 BLAKE2B 55d05f00cd0c7999feb4f6201083c2117bbf1bdf68ad65c0db7d142f258ed1d1aaabea2f3f4428861a3098048ddd2959714c6c5dd3a146cee09d382d04a89067 SHA512 b216777fa599047ee74eba16b4111c5f1ac0b370bb5155d0861196f31102037e3bde6ca93c8fa8169ab45faad0c463a1080064e763aed49ed395a9e45da37a06
+DIST clipman-1.6.1.tar.gz 21089 BLAKE2B fdee917c65336c260d4b90d58083474c14e439c5e55f0af587ae65a053daef4d7845d3aadc5781de5fd0fe4f382235fe5227a7118022af2177618f77ac14b613 SHA512 4d02cad58a5637df64a32673406632a9626633fa2bfc6cff28dc6c724048a3f6e40482a3f0eca64ad0af2e0100b426d8779beef29f24e28b5c494878ae1c0ef4
diff --git a/gui-apps/clipman/clipman-1.6.1.ebuild b/gui-apps/clipman/clipman-1.6.1.ebuild
new file mode 100644
index 000000000..f18bfc8e7
--- /dev/null
+++ b/gui-apps/clipman/clipman-1.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A basic clipboard manager for Wayland."
+HOMEPAGE="https://github.com/yory8/clipman"
+SRC_URI="https://github.com/yory8/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# Using a dependency tarball as per https://devmanual.gentoo.org/eclass-reference/go-module.eclass/index.html
+DEPS_URI="https://kdrive.infomaniak.com/app/share/192129/afaeda87-1372-40fc-b165-d509de1e747a/19/download -> ${P}-deps.tar.xz"
+SRC_URI+=" ${DEPS_URI}"
+
+LICENSE="BSD GPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+man"
+
+DEPEND="
+ >=gui-apps/wl-clipboard-2
+ gui-libs/wlroots
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-lang/go
+"
+
+src_compile() {
+ ego build .
+}
+
+src_install() {
+ dobin ${PN}
+ use man && doman docs/${PN}.1
+ default
+}
diff --git a/gui-apps/clipman/metadata.xml b/gui-apps/clipman/metadata.xml
new file mode 100644
index 000000000..0354b0e34
--- /dev/null
+++ b/gui-apps/clipman/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>freijon@pm.me</email>
+ <name>Jonas Frei</name>
+ </maintainer>
+</pkgmetadata>