aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@outlook.com>2022-08-02 13:40:56 -0500
committerLeonardo Hernández Hernández <leohdz172@outlook.com>2022-08-02 13:43:41 -0500
commitdfbb83fdea1884810c809f3ca0a7f5ed135032cd (patch)
tree6e00afad2e90148047e3c22eaf6a434924eb9536 /net-mail
parentsec-keys/openpgp-keys-emersion: new package, add 20220802 (diff)
downloadguru-dfbb83fdea1884810c809f3ca0a7f5ed135032cd.tar.gz
guru-dfbb83fdea1884810c809f3ca0a7f5ed135032cd.tar.bz2
guru-dfbb83fdea1884810c809f3ca0a7f5ed135032cd.zip
net-mail/hydroxide: new package, add 0.2.23, 9999
Signed-off-by: Leonardo Hernández Hernández <leohdz172@outlook.com>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/hydroxide/Manifest3
-rw-r--r--net-mail/hydroxide/hydroxide-0.2.23.ebuild56
-rw-r--r--net-mail/hydroxide/hydroxide-9999.ebuild56
-rw-r--r--net-mail/hydroxide/metadata.xml12
4 files changed, 127 insertions, 0 deletions
diff --git a/net-mail/hydroxide/Manifest b/net-mail/hydroxide/Manifest
new file mode 100644
index 000000000..6ccab93da
--- /dev/null
+++ b/net-mail/hydroxide/Manifest
@@ -0,0 +1,3 @@
+DIST hydroxide-0.2.23-deps.tar.xz 24543788 BLAKE2B 589d9a1f9c65ea192817f76bb00cce56d9d1bfa4c496dd392fbab65edaee34ac850fcc55d05d8ec944c49d98a7432bf4e2b4271e7acbc870d9bf115c4f0a8002 SHA512 ab1dfbc65677caac4d51e6e6301328046811e0359c45552e702da5605e990152040cdc6eec2920d7dd914cbdaf15d8179ae41a9a51d5e0b507c442d875516caf
+DIST hydroxide-0.2.23.tar.gz 43602 BLAKE2B d238758a67475620325ac7b267aa714a84871d45762f22547798dddc0562419988c382cb79a314d7239dd5fa9eafd407ae1cc20a491391a14ef872af36ad3495 SHA512 9f2c9b59cb7c1dfcfec9cc626767f340b1d5caea4db69e81de6b87c4bcf26840d14cd6568a0d3aad36d8e31184e2f1827a5e27745338bc2f38265ce64fe2d4a4
+DIST hydroxide-0.2.23.tar.gz.sig 566 BLAKE2B f8ba4f03ea9dd41f79cade5acdf19ef29ed40cb456465240ea60ba7bdfed86e5c842a9b74d78e4c49629de86d8d0630bd54b23923d50df926df2203fc0a5d543 SHA512 e2f87ec14412720479cdfc854268bd2422080bdf528491cf3d004f9e46e86fa5872f853b4085513c28f2a929a8f799a4f30538e66496f93aebc81a06a0ff584e
diff --git a/net-mail/hydroxide/hydroxide-0.2.23.ebuild b/net-mail/hydroxide/hydroxide-0.2.23.ebuild
new file mode 100644
index 000000000..e41adf553
--- /dev/null
+++ b/net-mail/hydroxide/hydroxide-0.2.23.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/hydroxide.git"
+else
+ inherit verify-sig
+ SRC_URI="https://github.com/emersion/${PN}/releases/download/v${PV}/${P}.tar.gz
+ verify-sig? ( https://github.com/emersion/${PN}/releases/download/v${PV}/${P}.tar.gz.sig )
+ https://gitlab.com/sevz17/go-deps/-/raw/main/${P}-deps.tar.xz
+ "
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/emersion.asc"
+ BDEPEND+="verify-sig? ( sec-keys/opengpg-keys-emersion )"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A third-party, open-source ProtonMail CardDAV, IMAP and SMTP bridge"
+HOMEPAGE="https://github.com/emersion/hydroxide"
+
+LICENSE="MIT BSD"
+SLOT="0"
+
+src_unpack() {
+ if [[ "${PV}" == *9999* ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ else
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/"${P}".tar.gz{,.sig}
+ fi
+ go-module_src_unpack
+ fi
+}
+
+src_compile() {
+ ego build -v ./cmd/hydroxide
+}
+
+src_install() {
+ local DOCS=( "LICENSE" "README.md" )
+ einstalldocs
+
+ dobin "${PN}"
+}
+
+pkg_postinst() {
+ elog ""
+ elog "In order to use ${PN} you need to read"
+ elog "https://github.com/emersion/hydroxide#installing"
+ elog ""
+}
diff --git a/net-mail/hydroxide/hydroxide-9999.ebuild b/net-mail/hydroxide/hydroxide-9999.ebuild
new file mode 100644
index 000000000..ea47dd123
--- /dev/null
+++ b/net-mail/hydroxide/hydroxide-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/hydroxide.git"
+else
+ inherit verify-sig
+ SRC_URI="https://github.com/emersion/${PN}/releases/download/v${PV}/${P}.tar.gz
+ verify-sig? ( https://github.com/emersion/${PN}/releases/download/v${PV}/${P}.tar.gz.sig )
+ https://gitlab.com/sevz17/go-deps/-/raw/main/${P}-deps.tar.xz
+ "
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/emersion.asc"
+ BDEPEND+="verify-sig? ( sec-keys/opengpg-keys-emersion )"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A third-party, open-source ProtonMail CardDAV, IMAP and SMTP bridge"
+HOMEPAGE="https://github.com/emersion/hydroxide"
+
+LICENSE="MIT BSD"
+SLOT="0"
+
+src_unpack() {
+ if [[ "${PV}" == "9999" ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ else
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/"${P}".tar.gz{,.sig}
+ fi
+ go-module_src_unpack
+ fi
+}
+
+src_compile() {
+ ego build -v ./cmd/hydroxide
+}
+
+src_install() {
+ local DOCS=( "LICENSE" "README.md" )
+ einstalldocs
+
+ dobin "${PN}"
+}
+
+pkg_postinst() {
+ elog ""
+ elog "In order to use ${PN} you need to read"
+ elog "https://github.com/emersion/hydroxide#installing"
+ elog ""
+}
diff --git a/net-mail/hydroxide/metadata.xml b/net-mail/hydroxide/metadata.xml
new file mode 100644
index 000000000..15a76dc83
--- /dev/null
+++ b/net-mail/hydroxide/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>leohdz172@outlook.com</email>
+ <name>Leonardo Hernández Hernández</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/emersion/hydroxide/issues</bugs-to>
+ <doc>https://github.com/emersion/hydroxide/blob/master/README.md</doc>
+ </upstream>
+</pkgmetadata>