aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-01 02:29:30 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-03 20:31:58 +0200
commitf6ff4d0bd7d12ea03f4c1d49fb687fed5b9baf4a (patch)
tree5148a5e39c145f8d6a4681482ddb8b231f460cbb /sci-geosciences
parentdev-js/*: pelias-openstreetmap dependencies (diff)
downloadguru-f6ff4d0bd7d12ea03f4c1d49fb687fed5b9baf4a.tar.gz
guru-f6ff4d0bd7d12ea03f4c1d49fb687fed5b9baf4a.tar.bz2
guru-f6ff4d0bd7d12ea03f4c1d49fb687fed5b9baf4a.zip
sci-geosciences/pelias-openstreetmap: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/pelias-openstreetmap/Manifest1
-rw-r--r--sci-geosciences/pelias-openstreetmap/metadata.xml12
-rw-r--r--sci-geosciences/pelias-openstreetmap/pelias-openstreetmap-5.10.2.ebuild56
3 files changed, 69 insertions, 0 deletions
diff --git a/sci-geosciences/pelias-openstreetmap/Manifest b/sci-geosciences/pelias-openstreetmap/Manifest
new file mode 100644
index 000000000..2661cdd70
--- /dev/null
+++ b/sci-geosciences/pelias-openstreetmap/Manifest
@@ -0,0 +1 @@
+DIST pelias-openstreetmap-5.10.2.tgz 20117 BLAKE2B a34067da7413acf3c10f2277aa82822da219b95190f57718832982c0899c794cb5851ffed8b91819bff453d340df5e071a1cf645920b9e7baf331dfe58a9e82a SHA512 b64351874ea93ec7cdd9a170ea0b6559a1acfc5e5e26d2f6f95c97cba237ebd709ec67b2751d65681a782f231402e6978c0c2d42b8c7e50bf6da4a865a603887
diff --git a/sci-geosciences/pelias-openstreetmap/metadata.xml b/sci-geosciences/pelias-openstreetmap/metadata.xml
new file mode 100644
index 000000000..bc660aa47
--- /dev/null
+++ b/sci-geosciences/pelias-openstreetmap/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/mapzen/pelias-openstreetmap/issues</bugs-to>
+ <remote-id type="github">mapzen/pelias-openstreetmap</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-geosciences/pelias-openstreetmap/pelias-openstreetmap-5.10.2.ebuild b/sci-geosciences/pelias-openstreetmap/pelias-openstreetmap-5.10.2.ebuild
new file mode 100644
index 000000000..142afa0da
--- /dev/null
+++ b/sci-geosciences/pelias-openstreetmap/pelias-openstreetmap-5.10.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit node
+
+DESCRIPTION="Pelias openstreetmap utilities"
+HOMEPAGE="
+ https://github.com/mapzen/pelias-openstreetmap
+ https://www.npmjs.com/package/pelias-openstreetmap
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE="test"
+#no tests in tarball
+RESTRICT="test"
+
+BDEPEND="
+ ${NODEJS_BDEPEND}
+ test? (
+ dev-js/colors
+ dev-js/deep-diff
+ dev-js/istanbul
+ dev-js/jshint
+ dev-js/naivedb
+ dev-js/pelias-mock-logger
+ dev-js/precommit-hook
+ dev-js/proxyquire
+ dev-js/stream-mock
+ dev-js/taginfo
+ dev-js/tap-spec
+ dev-js/tape
+ )
+"
+RDEPEND="
+ ${NODEJS_RDEPEND}
+ dev-js/async
+ dev-js/combined-stream
+ dev-js/extend
+ dev-js/is-object
+ dev-js/iso_639_3
+ dev-js/joi
+ dev-js/lodash
+ dev-js/merge
+ dev-js/pbf2json
+ dev-js/pelias-blacklist-stream
+ dev-js/pelias-config
+ dev-js/pelias-dbclient
+ dev-js/pelias-logger
+ dev-js/pelias-model
+ dev-js/pelias-wof-admin-lookup
+ dev-js/through2
+ dev-js/through2-sink
+"