aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office')
-rw-r--r--app-office/khronos/Manifest1
-rw-r--r--app-office/khronos/khronos-3.7.0.ebuild50
-rw-r--r--app-office/khronos/metadata.xml11
3 files changed, 62 insertions, 0 deletions
diff --git a/app-office/khronos/Manifest b/app-office/khronos/Manifest
new file mode 100644
index 000000000..d9ff63dd9
--- /dev/null
+++ b/app-office/khronos/Manifest
@@ -0,0 +1 @@
+DIST khronos-3.7.0.tar.gz 103609 BLAKE2B 10662eeb842330e5571379c80febbde861f7d788e16b2b5dfb94cb3be9558cf03ab0983cc43873761c8f895a0ac7f3f5d6f0f699f671b0adb0ef96c315d17cb6 SHA512 98f4ae9426b2c6f7b9eb590ffdf8c8c1d0dc190c9a572d5826098ca654aabbb2d0a0eef080dc3a5f62234df0749bf91d0366cd2e06c5a1c1d0dec6f0a9e42e14
diff --git a/app-office/khronos/khronos-3.7.0.ebuild b/app-office/khronos/khronos-3.7.0.ebuild
new file mode 100644
index 000000000..65513c304
--- /dev/null
+++ b/app-office/khronos/khronos-3.7.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg gnome2-utils vala
+
+DESCRIPTION="A GTK4 time tracker for tasks"
+HOMEPAGE="https://apps.gnome.org/app/io.github.lainsce.Khronos"
+SRC_URI="https://github.com/lainsce/khronos/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IDEPEND="
+ >=gui-libs/gtk-4.6
+ >=gui-libs/libadwaita-1
+ >=dev-libs/libgee-0.20.6
+ >=dev-libs/json-glib-1.6.6-r1
+"
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-lang/vala-0.56.8
+ >=dev-util/meson-1.1.1
+ >=dev-util/ninja-1.11.1-r2
+ $(vala_depend)
+"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+
+ sed -i \
+ -e '/^gnome.post_install(/,/)/d' \
+ meson.build \
+ || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-office/khronos/metadata.xml b/app-office/khronos/metadata.xml
new file mode 100644
index 000000000..368d10d60
--- /dev/null
+++ b/app-office/khronos/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mail@konstantintutsch.de</email>
+ <name>Konstantin Tutsch</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lainsce/khronos</remote-id>
+ </upstream>
+</pkgmetadata>