summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-06-07 22:58:24 +0100
committerMarek Szuba <marecki@gentoo.org>2023-06-07 22:58:24 +0100
commit37fde8d5c1acb190c25d63622f7b427482da28e5 (patch)
treeca33da8f5925f6ddf4d4f6a4a5e780d3b4cefe6f
parentnet-p2p/syncthing: add 1.23.5 (diff)
downloadgentoo-37fde8d5c1acb190c25d63622f7b427482da28e5.tar.gz
gentoo-37fde8d5c1acb190c25d63622f7b427482da28e5.tar.bz2
gentoo-37fde8d5c1acb190c25d63622f7b427482da28e5.zip
app-backup/borgmatic: add 1.7.14
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.7.14.ebuild73
-rw-r--r--app-backup/borgmatic/files/borgmatic-1.7.14-systemd_service_bin_path.patch8
3 files changed, 82 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index 98dc0531ada5..fcd57574c6a2 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,3 +1,4 @@
DIST borgmatic-1.7.11.tar.gz 365247 BLAKE2B a06737c48722fdf24efca76d40f6b413f39635b4137685d6279bf7a7dd002fadef28dab35a503fabf872c732a0f32fbff8c791fa9b4602299937aeae568d6137 SHA512 cedca889cd409e92484c15240fd8da91c655f81e38c6672d25e44feedc4adf6594281d92f7072fd11edc5c9f8589098226a3520e71e3441ee7a7acf97e1b2daa
DIST borgmatic-1.7.13.tar.gz 378163 BLAKE2B c20b384853c0ddf52a095250a05d9ebe813a23ee6ef00bd5748dacf05adcff9e4d324eb2e785ebbf139d34cadab3e58d3b8305d50ec5ff20681630040433e5ae SHA512 5109c093ad3096269e27abe761e6e87ebc31b78a56bfe16e540c686ea1cd935249d063aa7c350b60a3c509990065f3a50f9e4516d40d4a1bde68c43617de18b4
+DIST borgmatic-1.7.14.tar.gz 380875 BLAKE2B c30939392df03ce03feed4c5132ef99eaf9c676f51f7ad6b8bd536f45a7e76eff1871fc5bf0d7fd0025835b51325e961f538a661f2f6a78e0ce026550a9ecd84 SHA512 15f774b994d13ab224bcbcb0335145b5cf9a2fca04b098c15bf790c20fc5033073fe341a76d4e9dc8ad85e5fb898a0447c73fc5bc74d0ac9ec6900c333e6660b
DIST borgmatic-1.7.8.tar.gz 350233 BLAKE2B 3fcd392983f73ec5e97f0dc6b96e211d7f1e1d1a4ce95c635c675cf043e796925df53c30c1e4f8eb1a095d9ec5ff81e90edee5ff2576f4683053d3108004afd9 SHA512 bcc65fdb7ea1171fb61deda9b1f69a00596e1e10a99508d336977b694bd8f93d74837aad9211bf1065b785220aaf1460a3ea403bf23fa4873d1bf4c6b4016525
diff --git a/app-backup/borgmatic/borgmatic-1.7.14.ebuild b/app-backup/borgmatic/borgmatic-1.7.14.ebuild
new file mode 100644
index 000000000000..4cd57ed17ff4
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.7.14.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.13-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.7.14-systemd_service_bin_path.patch
+)
+
+# A fragile test whose only purpose is to make sure the NEWS file
+# has been updated for the current version.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " generate-borgmatic-config"
+ else
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.7.11; then
+ ewarn "Since version 1.7.11 ${PN} defaults to a different way of selecting archives for multi-archive actions."
+ ewarn "For details, please see"
+ ewarn
+ ewarn " https://torsion.org/borgmatic/docs/how-to/make-per-application-backups/#archive-naming"
+ ewarn
+ break
+ fi
+ done
+ fi
+ elog
+ elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
+}
diff --git a/app-backup/borgmatic/files/borgmatic-1.7.14-systemd_service_bin_path.patch b/app-backup/borgmatic/files/borgmatic-1.7.14-systemd_service_bin_path.patch
new file mode 100644
index 000000000000..5e6f8b7482b5
--- /dev/null
+++ b/app-backup/borgmatic/files/borgmatic-1.7.14-systemd_service_bin_path.patch
@@ -0,0 +1,8 @@
+--- a/sample/systemd/borgmatic.service
++++ b/sample/systemd/borgmatic.service
+@@ -61,4 +61,4 @@
+ # Delay start to prevent backups running during boot. Note that systemd-inhibit requires dbus and
+ # dbus-user-session to be installed.
+ ExecStartPre=sleep 1m
+-ExecStart=systemd-inhibit --who="borgmatic" --what="sleep:shutdown" --why="Prevent interrupting scheduled backup" /root/.local/bin/borgmatic --verbosity -2 --syslog-verbosity 1
++ExecStart=systemd-inhibit --who="borgmatic" --what="sleep:shutdown" --why="Prevent interrupting scheduled backup" /usr/bin/borgmatic --verbosity -2 --syslog-verbosity 1