summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-05-02 11:07:50 +0200
committerJohannes Huber <johu@gentoo.org>2016-05-02 11:08:02 +0200
commit459f3c2c5db4a1e4f93e538dffbfc0e6eff93e3b (patch)
tree4172bf7b1950ffb9f06702aaf5e27eae5ba4738d
parentnet-misc/ntp: Stable for PPC64 (bug #581528). (diff)
downloadgentoo-459f3c2c5db4a1e4f93e538dffbfc0e6eff93e3b.tar.gz
gentoo-459f3c2c5db4a1e4f93e538dffbfc0e6eff93e3b.tar.bz2
gentoo-459f3c2c5db4a1e4f93e538dffbfc0e6eff93e3b.zip
media-libs/qimageblitz: Use system Qt4 cmake find module
Gentoo-bug: 581824 Package-Manager: portage-2.2.28
-rw-r--r--media-libs/qimageblitz/qimageblitz-0.0.6-r2.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/media-libs/qimageblitz/qimageblitz-0.0.6-r2.ebuild b/media-libs/qimageblitz/qimageblitz-0.0.6-r2.ebuild
index c57aa1c4b62c..673e4b3c703b 100644
--- a/media-libs/qimageblitz/qimageblitz-0.0.6-r2.ebuild
+++ b/media-libs/qimageblitz/qimageblitz-0.0.6-r2.ebuild
@@ -27,6 +27,13 @@ PATCHES=(
"${FILESDIR}/${P}-cmake.patch"
)
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # bug 581824: use system find module for Qt4
+ rm -f cmake/modules/FindQt4.cmake || die
+}
+
src_configure() {
local mycmakeargs=(
-DHAVE_ALTIVEC=$(usex altivec)