summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-08 17:43:37 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-09 03:33:43 +0200
commit907305456cfd8197e012098bfaae3cfc6c494a29 (patch)
tree7daa04d8abb38a5aa3baf5c195a5789c13cd89e1
parentmedia-plugins/grilo-plugins: Stabilize 0.3.16 amd64, #907626 (diff)
downloadgentoo-907305456cfd8197e012098bfaae3cfc6c494a29.tar.gz
gentoo-907305456cfd8197e012098bfaae3cfc6c494a29.tar.bz2
gentoo-907305456cfd8197e012098bfaae3cfc6c494a29.zip
dev-python/requests-mock: Bump to 1.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/requests-mock/Manifest1
-rw-r--r--dev-python/requests-mock/requests-mock-1.11.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/requests-mock/Manifest b/dev-python/requests-mock/Manifest
index 5bc4b0672627..52b7c33a8684 100644
--- a/dev-python/requests-mock/Manifest
+++ b/dev-python/requests-mock/Manifest
@@ -1 +1,2 @@
DIST requests-mock-1.10.0.tar.gz 72627 BLAKE2B 4ce1838f03b732de4007c2e9b700876dcf8dba0f5eafef1292e0e40ae75e08f9b3bf74c3620d2d762944ccf9af248304929f57a337122b1a69d13355dc3f290e SHA512 873c9b219e2a2360872fac22c83371ce40f4dee45e6a0d40365f4f551271c2168a662dced6e8baad890b1dadfc03d21d4ce013f149d25a42d998af4f4fca2a79
+DIST requests-mock-1.11.0.tar.gz 74377 BLAKE2B f871bbd18b42668d9eb693b807a67a33c9fb7c4316966ad2c16800bf562be982c737e1c1a803e3c5b6d3cde8c3d789671b5fce7d54df308dc55b2ef73a641ff4 SHA512 8d161cb0f6183994053d4dd06b801c2614b7ac937798addcdc52ee8e3973a7ef874ca615ca1946ea4bc0e05ce36c5c813460f7a41b3254671095059536fd2961
diff --git a/dev-python/requests-mock/requests-mock-1.11.0.ebuild b/dev-python/requests-mock/requests-mock-1.11.0.ebuild
new file mode 100644
index 000000000000..bdcf3889474d
--- /dev/null
+++ b/dev-python/requests-mock/requests-mock-1.11.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Mock out responses from the requests package"
+HOMEPAGE="
+ https://github.com/jamielennox/requests-mock/
+ https://pypi.org/project/requests-mock/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.3[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests-futures[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Disable reno which only works inside a git repository
+ sed -i "s/'reno.sphinxext',//" doc/source/conf.py || die
+ # Remove the release notes section which requires reno
+ rm doc/source/release-notes.rst || die
+ sed -i '/^=============$/,/release-notes/d' doc/source/index.rst || die
+ # Disable a test which requires purl (not in the tree)
+ sed -e "/^import purl$/d" -e "s/test_with_purl/_&/" \
+ -i tests/test_adapter.py || die
+ distutils-r1_python_prepare_all
+}