summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2023-01-21 10:12:58 +0900
committerAkinori Hattori <hattya@gentoo.org>2023-01-21 10:15:15 +0900
commitd2eaeec879db955468846a71b56a2a8c62f32aab (patch)
tree851f14f5b4262a5beb6899c53d233e57a6c50ba0
parentapp-i18n/ibus-typing-booster: drop old (diff)
downloadgentoo-d2eaeec879db955468846a71b56a2a8c62f32aab.tar.gz
gentoo-d2eaeec879db955468846a71b56a2a8c62f32aab.tar.bz2
gentoo-d2eaeec879db955468846a71b56a2a8c62f32aab.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.19.13.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 1a2fc26ab5bb..0f575aacadfe 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1 +1,2 @@
DIST ibus-typing-booster-2.19.10.tar.gz 11174125 BLAKE2B e180a72dc59d89838696291e767e994a17794a7565cf08cbe547aafa75dc73c5e58b046b2312fe70cc682bd9fcc93db23679e62af5ecfe3bd391dee38b73a697 SHA512 af9952aac45906400fdbb8421165c91cc8ade898a20331cb7ba6f85d18a73a8a872f38c00e6ec35c4c6048541f56d4d3f43e8c222fda975efa28c1d6b86d99ee
+DIST ibus-typing-booster-2.19.13.tar.gz 11175082 BLAKE2B 4f0925c38a272b056ec3e542059416d65d6bcdd26a1e5810ea8a6febbd9a3c7c0d8cd74b75826622e70fd04aeeb2282e166c3433f86233be0bf6929fac58dece SHA512 78a29efd5df8380db274b0e8f14aea83bb2841bae78b6c49cb28151b6dc011a5856bfc4f2347c4295dc2fbe058df150e06346fe4eee7ca331edf73e5fedebd2e
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.19.13.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.19.13.ebuild
new file mode 100644
index 000000000000..3a255c68af99
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.19.13.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}