summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2023-08-19 09:33:47 -0400
committerRick Farina <zerochaos@gentoo.org>2023-08-19 09:33:47 -0400
commite4af2261fe513e9d54e2fdcf315be88b2809e800 (patch)
tree6c2361594567dbd73eb99db0cd70713ebbd5d15b
parentnet-wireless/uhd: drop 4.3.0.0 (diff)
downloadgentoo-e4af2261fe513e9d54e2fdcf315be88b2809e800.tar.gz
gentoo-e4af2261fe513e9d54e2fdcf315be88b2809e800.tar.bz2
gentoo-e4af2261fe513e9d54e2fdcf315be88b2809e800.zip
net-wireless/ubertooth: update HOMEPAGE
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
-rw-r--r--net-wireless/ubertooth/ubertooth-2020.12.1-r1.ebuild11
-rw-r--r--net-wireless/ubertooth/ubertooth-9999.ebuild11
2 files changed, 14 insertions, 8 deletions
diff --git a/net-wireless/ubertooth/ubertooth-2020.12.1-r1.ebuild b/net-wireless/ubertooth/ubertooth-2020.12.1-r1.ebuild
index 8e986934be2b..45856c5f06e4 100644
--- a/net-wireless/ubertooth/ubertooth-2020.12.1-r1.ebuild
+++ b/net-wireless/ubertooth/ubertooth-2020.12.1-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
inherit cmake udev
-HOMEPAGE="http://ubertooth.sourceforge.net/"
+HOMEPAGE="https://greatscottgadgets.com/ubertoothone/"
LICENSE="GPL-2"
SLOT="0"
@@ -32,7 +32,8 @@ fi
DESCRIPTION="open source wireless development platform suitable for Bluetooth experimentation"
#readd firmware building, but do it right
-#USE="-fortran -mudflap -nls -openmp -multilib" crossdev --without-headers --genv 'EXTRA_ECONF="--with-mode=thumb --with-cpu=cortex-m3 --with-float=soft"' -s4 -t arm-cortexm3-eabi
+#USE="-fortran -mudflap -nls -openmp -multilib" crossdev --without-headers --genv \
+#'EXTRA_ECONF="--with-mode=thumb --with-cpu=cortex-m3 --with-float=soft"' -s4 -t arm-cortexm3-eabi
src_configure() {
local mycmakeargs=(
@@ -59,8 +60,10 @@ src_install() {
ewarn "Firmware isn't available for git releases, we assume you are already"
ewarn "on the latest and/or can build your own."
else
- use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rxtx.dfu ${PN}-one-${PV}-bluetooth_rxtx.dfu
- use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rx_only.dfu ${PN}-one-${PV}-bluetooth_rx_only.dfu
+ if use ubertooth1-firmware; then
+ newins ubertooth-one-firmware-bin/bluetooth_rxtx.dfu ${PN}-one-${PV}-bluetooth_rxtx.dfu
+ newins ubertooth-one-firmware-bin/bluetooth_rx_only.dfu ${PN}-one-${PV}-bluetooth_rx_only.dfu
+ fi
fi
popd
diff --git a/net-wireless/ubertooth/ubertooth-9999.ebuild b/net-wireless/ubertooth/ubertooth-9999.ebuild
index 580e009cffa1..719d5adfaf80 100644
--- a/net-wireless/ubertooth/ubertooth-9999.ebuild
+++ b/net-wireless/ubertooth/ubertooth-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
inherit cmake udev
-HOMEPAGE="http://ubertooth.sourceforge.net/"
+HOMEPAGE="https://greatscottgadgets.com/ubertoothone/"
LICENSE="GPL-2"
SLOT="0"
@@ -32,7 +32,8 @@ fi
DESCRIPTION="open source wireless development platform suitable for Bluetooth experimentation"
#readd firmware building, but do it right
-#USE="-fortran -mudflap -nls -openmp -multilib" crossdev --without-headers --genv 'EXTRA_ECONF="--with-mode=thumb --with-cpu=cortex-m3 --with-float=soft"' -s4 -t arm-cortexm3-eabi
+#USE="-fortran -mudflap -nls -openmp -multilib" crossdev --without-headers --genv \
+#'EXTRA_ECONF="--with-mode=thumb --with-cpu=cortex-m3 --with-float=soft"' -s4 -t arm-cortexm3-eabi
src_configure() {
local mycmakeargs=(
@@ -59,8 +60,10 @@ src_install() {
ewarn "Firmware isn't available for git releases, we assume you are already"
ewarn "on the latest and/or can build your own."
else
- use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rxtx.dfu ${PN}-one-${PV}-bluetooth_rxtx.dfu
- use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rx_only.dfu ${PN}-one-${PV}-bluetooth_rx_only.dfu
+ if use ubertooth1-firmware; then
+ newins ubertooth-one-firmware-bin/bluetooth_rxtx.dfu ${PN}-one-${PV}-bluetooth_rxtx.dfu
+ newins ubertooth-one-firmware-bin/bluetooth_rx_only.dfu ${PN}-one-${PV}-bluetooth_rx_only.dfu
+ fi
fi
popd