summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2017-08-28 17:38:31 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2017-08-28 17:39:04 +0200
commitc9eb5579f753ed8995f9164853fcdfc92333a998 (patch)
tree2fb2834ecf9cb0da2a5417aa8f88cb02e1d14769 /app-admin/logrotate
parentdev-util/shadowman: use ${ED} for prefix compatibility (diff)
downloadgentoo-c9eb5579f753ed8995f9164853fcdfc92333a998.tar.gz
gentoo-c9eb5579f753ed8995f9164853fcdfc92333a998.tar.bz2
gentoo-c9eb5579f753ed8995f9164853fcdfc92333a998.zip
app-admin/logrotate: Reverts changes in bug 621850
Gentoo-Bug: 627698 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-admin/logrotate')
-rw-r--r--app-admin/logrotate/logrotate-3.12.3-r1.ebuild94
-rw-r--r--app-admin/logrotate/metadata.xml1
2 files changed, 94 insertions, 1 deletions
diff --git a/app-admin/logrotate/logrotate-3.12.3-r1.ebuild b/app-admin/logrotate/logrotate-3.12.3-r1.ebuild
new file mode 100644
index 000000000000..6e1b74085b82
--- /dev/null
+++ b/app-admin/logrotate/logrotate-3.12.3-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+DESCRIPTION="Rotates, compresses, and mails system logs"
+HOMEPAGE="https://github.com/logrotate/logrotate"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="acl +cron selinux"
+
+CDEPEND="
+ >=dev-libs/popt-1.5
+ selinux? ( sys-libs/libselinux )
+ acl? ( virtual/acl )"
+
+DEPEND="${CDEPEND}
+ >=sys-apps/sed-4"
+
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-logrotate )
+ cron? ( virtual/cron )"
+
+STATEFILE="/var/lib/misc/logrotate.status"
+OLDSTATEFILE="/var/lib/logrotate.status"
+
+move_old_state_file() {
+ elog "logrotate state file is now located at ${STATEFILE}"
+ elog "See bug #357275"
+ if [[ -e "${OLDSTATEFILE}" ]] ; then
+ elog "Moving your current state file to new location: ${STATEFILE}"
+ mv -n "${OLDSTATEFILE}" "${STATEFILE}"
+ fi
+}
+
+install_cron_file() {
+ exeinto /etc/cron.daily
+ newexe "${S}"/examples/logrotate.cron "${PN}"
+}
+
+PATCHES=(
+ "${FILESDIR}/${P}-ignore-hidden.patch"
+ "${FILESDIR}/${P}-fbsd.patch"
+)
+
+src_prepare() {
+ default
+ sed -i -e 's#/usr/sbin/logrotate#/usr/bin/logrotate#' "${S}"/examples/logrotate.{cron,service} || die
+}
+
+src_configure() {
+ econf $(use_with acl) $(use_with selinux) --with-state-file-path="${STATEFILE}"
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ insinto /usr
+ dobin logrotate
+ doman logrotate.8
+ dodoc ChangeLog.md examples/logrotate-default
+
+ insinto /etc
+ doins "${FILESDIR}"/logrotate.conf
+
+ use cron && install_cron_file
+
+ systemd_dounit examples/logrotate.{service,timer}
+
+ keepdir /etc/logrotate.d
+}
+
+pkg_postinst() {
+ elog "The ${PN} binary is now installed under /usr/bin. Please"
+ elog "update your links"
+ elog
+ move_old_state_file
+ elog
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "If you wish to have logrotate e-mail you updates, please"
+ elog "emerge virtual/mailx and configure logrotate in"
+ elog "/etc/logrotate.conf appropriately"
+ elog
+ elog "Additionally, /etc/logrotate.conf may need to be modified"
+ elog "for your particular needs. See man logrotate for details."
+ fi
+}
diff --git a/app-admin/logrotate/metadata.xml b/app-admin/logrotate/metadata.xml
index de61486807ac..e5648d41d70a 100644
--- a/app-admin/logrotate/metadata.xml
+++ b/app-admin/logrotate/metadata.xml
@@ -22,7 +22,6 @@
<flag name="acl">Installs acl support</flag>
<flag name="cron">Installs cron file</flag>
<flag name="selinux">Installs Security Enhanced Linux support</flag>
- <flag name="bzip2">Compresses rotated log files with bzip2 instead of gzip</flag>
</use>
<upstream>
<remote-id type="github">logrotate/logrotate</remote-id>