summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-06-16 17:34:32 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-06-16 17:34:32 -0500
commit40df0ea406dd144f233cc8c243dffde056656155 (patch)
tree04618422ef0270d62dd5a4968108d178b33c2819 /app-admin/terraform
parentcommon-lisp-3.eclass: Don't call readarray -d unless >=bash-5.0 (diff)
downloadgentoo-40df0ea406dd144f233cc8c243dffde056656155.tar.gz
gentoo-40df0ea406dd144f233cc8c243dffde056656155.tar.bz2
gentoo-40df0ea406dd144f233cc8c243dffde056656155.zip
app-admin/terraform: add 1.5.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-admin/terraform')
-rw-r--r--app-admin/terraform/Manifest2
-rw-r--r--app-admin/terraform/terraform-1.5.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/terraform/Manifest b/app-admin/terraform/Manifest
index a57a5a4cd8b2..678aff69c548 100644
--- a/app-admin/terraform/Manifest
+++ b/app-admin/terraform/Manifest
@@ -4,3 +4,5 @@ DIST terraform-1.4.2-deps.tar.xz 297847412 BLAKE2B 3a9cae729ae0f059f50a7f41a3300
DIST terraform-1.4.2.tar.gz 5111071 BLAKE2B ec79eae36c9e462fa94afe2127343fd7f1e4e629b077fd6ccaea092cc53bfa74add2407070bc0925f81c12e51f758561e535aae298b8fee5d9fffa32b86bed57 SHA512 66b937dae65c12eddfca9a4b95294fe5fff2ccb79f2afcd8ec47d227e0a36f8edba4190939d59c80a78a0752c42e43085e30f09ea66fd06531dc9cfe30fd78f2
DIST terraform-1.4.6-deps.tar.xz 297873376 BLAKE2B d4346810ea5dd0043524637192b8ba669d9d175857e2b96c1e40865ab7339b27f0e36651ead8bb122f7aae595202817b368d95f0cc38ac31a21e93834594eecb SHA512 59ae5a575ab8b971e2a890c4e87548b126b02941d0bc58103080f26a0c092851030a372b64324b0ec83eac85aa683a1a4211ce385d2461afd1584e2037faa255
DIST terraform-1.4.6.tar.gz 5118386 BLAKE2B 8015945c4e1cc4fff91b2b72a26182cfba6430d0268b00ae7345b4f29690d8876dfc55ec535342ef194d0674b8b9360abb046f3e56161cbcef27d0c7e02c1cbc SHA512 635ebadb275218a348b8d386aeed72bc8cc740d931ee5feea896ced80709d83ba265d40e0a335ec816e9568e42272075e3213670df23e603e342d94f3f42830a
+DIST terraform-1.5.0-deps.tar.xz 297939668 BLAKE2B 12fc9e87096a08b1ac893e48872e0dc636afbcdb8c36b721ffeb5b34dff0ac377b5c1fa77d8679017bd98bb4973c34fd4055373fcb628ad63c02646c289f4692 SHA512 b6ceb57cd35c670526046f61bc3ab5f9677816d061b77079d1afe4ab8aa5665f894b3066b40ccf225bd73f12a21fc74610b7eb42907f1dbb1e1c0e1823804399
+DIST terraform-1.5.0.tar.gz 5389374 BLAKE2B be4026ccd9b077dcdc51e606693a9dc6fc12f9dee9d704c2f2347dcc43fd2232b31e5a7c3cdf407e3cf0f588f412c0fe9723fac70f2d872ed0723a3a7b827e28 SHA512 3b46ed8315881a5777ed346667e39ab896e595e9487340def7798c006afe5a63f49a47e20621b39d336582854129e22c63eb690e33648c408ccf5bc504add025
diff --git a/app-admin/terraform/terraform-1.5.0.ebuild b/app-admin/terraform/terraform-1.5.0.ebuild
new file mode 100644
index 000000000000..e3ee07fe5929
--- /dev/null
+++ b/app-admin/terraform/terraform-1.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
+HOMEPAGE="https://www.terraform.io/"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MPL-2.0 MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+BDEPEND="dev-go/gox"
+
+RESTRICT="test"
+
+DOCS=( {README,CHANGELOG}.md )
+
+src_compile() {
+ export CGO_ENABLED=0
+ gox \
+ -os=$(go env GOOS) \
+ -arch=$(go env GOARCH) \
+ -output bin/terraform \
+ -verbose \
+ . || die
+}
+
+src_install() {
+ dobin bin/*
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "If you would like to install shell completions please run:"
+ elog " terraform -install-autocomplete"
+}