summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-14 16:56:42 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-14 18:04:21 +0100
commitd6608064ef09f3e91c6655053b998d692d09ac6d (patch)
tree94c649c76b7b0192bf48583640fa4f0f5eaced76 /app-admin
parentdev-python/boto3: Bump to 1.21.18 (diff)
downloadgentoo-d6608064ef09f3e91c6655053b998d692d09ac6d.tar.gz
gentoo-d6608064ef09f3e91c6655053b998d692d09ac6d.tar.bz2
gentoo-d6608064ef09f3e91c6655053b998d692d09ac6d.zip
app-admin/awscli: Bump to 1.22.73
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.73.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index fc8ead8cec68..82c515b5d968 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -14,3 +14,4 @@ DIST awscli-1.22.62.tar.gz 2167585 BLAKE2B 39141893c979b0047a45a9aea210d03340fc8
DIST awscli-1.22.63.tar.gz 2167746 BLAKE2B e72126578c9bac30c6d66bdd178961a7a36a045788d8079e8f0ab4c85d18c29454255a13f089c03ef53bdce0949d168c858d03b59cf5d5326fb3de9925a3f487 SHA512 4d8a6ee8b81445fbb51dbb31e899bebb5610b0a1291654eb9b6555685dcb85528c2b928f587d9ff98507f60d2b199ac71c48f6e204e7eb2ce2ba5d7abdd31ec0
DIST awscli-1.22.70.tar.gz 2177284 BLAKE2B 1ba770ba1b1404d6ff31d95ee198cba41321fe79d618d8b2ab8258da75f9cc56d5af95851dbed837b65e4fdbd82193639da5614551fe2d7f0ebc20df44531615 SHA512 0f246e82cee70b8d16e1fc7e30aae67554f5186eb2a0251295b25eafe23d7b29293059be7ebffbe7a45c665d0bae210699093b86bf7b3e188017018d8329af84
DIST awscli-1.22.71.tar.gz 2177492 BLAKE2B 2634de77b67aedf1684370b18da614d8092da277d099a25aa9ca054743e851df0e4ace5ff8fd884faebb012ad4cc8f0c94892a6c2bc2e1f284c28663b029198b SHA512 a404177ee0b5012553dfa95734d424f744ecc3b4a800ccf6d7f27a0f3b9a93722e4f53e4aed095306ba575328686ef1768095cd796b11064e0b707fadcd1e90c
+DIST awscli-1.22.73.tar.gz 2178216 BLAKE2B 14cd910f0218c015c3f349f57f268b818737d12cede273d6d306eff5be7e68690df19bc1e3eaaf4d7069d233f171a12edd9144febf5f877c49189f0aa6786441 SHA512 a708eafb38891ef1119c9ebe690ef6a1ad8f21605621ddf63820f2a54bf5612d62179922b59150de67dca4d266c55198fdd69db04a234b8051c0b5e5c8fd6cc7
diff --git a/app-admin/awscli/awscli-1.22.73.ebuild b/app-admin/awscli/awscli-1.22.73.ebuild
new file mode 100644
index 000000000000..21a285d18863
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.73.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# awscli 1.22.55 → botocore 1.24.0
+# so botocore is x.(y+2).(z-55)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 55))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}