summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-15 16:16:11 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-15 20:27:15 +0100
commit0eb32aa7747c9936ef2aef94841563a3606768da (patch)
tree255449bb585143befb18716de203d42839f4ac8a /app-containers
parentnet-print/hplip: Stabilize 3.23.8 ppc, #917388 (diff)
downloadgentoo-0eb32aa7747c9936ef2aef94841563a3606768da.tar.gz
gentoo-0eb32aa7747c9936ef2aef94841563a3606768da.tar.bz2
gentoo-0eb32aa7747c9936ef2aef94841563a3606768da.zip
app-containers/devcontainer: bump to 0.53.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/devcontainer/Manifest1
-rw-r--r--app-containers/devcontainer/devcontainer-0.53.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-containers/devcontainer/Manifest b/app-containers/devcontainer/Manifest
index 8744645c47b7..fd38f362d051 100644
--- a/app-containers/devcontainer/Manifest
+++ b/app-containers/devcontainer/Manifest
@@ -1,2 +1,3 @@
DIST devcontainer-0.52.0.tgz 614149 BLAKE2B 1e71d4772ec799cf8709d1d350cb8db0ea61dd2c7e96be4d35555675f9784bb1ff71ba95b6816fa9f8b6bd62c9a2b801871d51ab9fd8b564052c5939be603e2f SHA512 1790c6f2933c343b17a52d87a065e78c6e90b59249efb14c4601fc39de9a89aa6a93d100664ad3180a779c01fc181a31e59026af6bd646c214a616c61aed634c
DIST devcontainer-0.52.1.tgz 614268 BLAKE2B e1e2979e7d105e0082db4019260b7015c6bab9899f43e75ff1246f879bd659557404ca2f10ffa021bd5cf2caaff6f0dad53ca8b8c48e7f082d00961c9982faf0 SHA512 b182b57071c356374121dc63301f0eebaf3ea9fd0000424f31b78c47d6536d4cd74013647bcf2f50e67a0c3f528eca9e1397acf12a565fa8d5ea0688b73245c8
+DIST devcontainer-0.53.0.tgz 614575 BLAKE2B b7279b629cae49da39eca9defa17055b94c95db8ed79f78ec869f15a361ae12b4142817433e789c0d1231a753a1c7cc0247d5de738981f0f17c61de82aa7a8c9 SHA512 942e3b4b4ab19de876f22fcad16a1b41e5edc271cafcbc3281f198a80156e44ea94217cfcb4e0ef63ca96e6e854e030f4f70a51e7bcc655f0cb8cf23dcf003dc
diff --git a/app-containers/devcontainer/devcontainer-0.53.0.ebuild b/app-containers/devcontainer/devcontainer-0.53.0.ebuild
new file mode 100644
index 000000000000..399665b46cde
--- /dev/null
+++ b/app-containers/devcontainer/devcontainer-0.53.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference implementation of the Development Containers specification"
+HOMEPAGE="https://containers.dev/
+ https://github.com/devcontainers/cli/"
+SRC_URI="https://registry.npmjs.org/@devcontainers/cli/-/cli-${PV}.tgz
+ -> ${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ net-libs/nodejs
+"
+BDEPEND="
+ >=net-libs/nodejs-16[npm]
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local -a my_npm_opts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}/usr"
+ --progress false
+ --verbose
+ )
+ npm "${my_npm_opts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"
+
+ einstalldocs
+}