summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-07-29 17:35:16 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-07-29 18:09:13 +0200
commit61ab83cc618bcae74e8b14331a7089efcb24e80c (patch)
treeb57015531493132650b4ae958fac1ad89798d660 /app-emacs/assess
parentx11-themes/fluent-icon-theme: drop old 2023.02.01 (diff)
downloadgentoo-61ab83cc618bcae74e8b14331a7089efcb24e80c.tar.gz
gentoo-61ab83cc618bcae74e8b14331a7089efcb24e80c.tar.bz2
gentoo-61ab83cc618bcae74e8b14331a7089efcb24e80c.zip
app-emacs/assess: remove broken tests
Closes: https://bugs.gentoo.org/911284 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/assess')
-rw-r--r--app-emacs/assess/assess-0.6.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/app-emacs/assess/assess-0.6.ebuild b/app-emacs/assess/assess-0.6.ebuild
index 6d09c2dc615c..95c83fa6db65 100644
--- a/app-emacs/assess/assess-0.6.ebuild
+++ b/app-emacs/assess/assess-0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,10 +7,17 @@ inherit elisp
DESCRIPTION="Test support functions for Emacs"
HOMEPAGE="https://github.com/phillord/assess/"
-SRC_URI="https://github.com/phillord/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/phillord/${PN}.git"
+else
+ SRC_URI="https://github.com/phillord/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="GPL-3+"
-KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -23,8 +30,9 @@ BDEPEND="
DOCS=( README.md )
-# Remove a test helper accessing the network, luckily unnecessary
-ELISP_REMOVE="test/local-sandbox.el"
+# Remove tests failing with Emacs >=29.
+# Remove a test helper accessing the network, luckily unnecessary.
+ELISP_REMOVE="test/assess-robot-test.el test/local-sandbox.el"
SITEFILE="50${PN}-gentoo.el"
src_test() {