summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-27 22:06:53 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-27 22:15:59 +0100
commit2e03e41079d3879f49fe679ebd75c8cedec84e62 (patch)
tree40d276f9ecc1ec48f496aef40bbe6d42b8c0d332 /app-i18n
parentsys-apps/isapnptools: Port to EAPI 6 (diff)
downloadgentoo-2e03e41079d3879f49fe679ebd75c8cedec84e62.tar.gz
gentoo-2e03e41079d3879f49fe679ebd75c8cedec84e62.tar.bz2
gentoo-2e03e41079d3879f49fe679ebd75c8cedec84e62.zip
app-i18n/imhangul: Port to EAPI 6
Bug: https://bugs.gentoo.org/621942 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/imhangul/imhangul-3.1.1.ebuild38
1 files changed, 19 insertions, 19 deletions
diff --git a/app-i18n/imhangul/imhangul-3.1.1.ebuild b/app-i18n/imhangul/imhangul-3.1.1.ebuild
index 6d32c1184876..1cebdc2d5fc8 100644
--- a/app-i18n/imhangul/imhangul-3.1.1.ebuild
+++ b/app-i18n/imhangul/imhangul-3.1.1.ebuild
@@ -1,15 +1,14 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
-inherit multilib
+EAPI=6
DESCRIPTION="Gtk+-3.0 Hangul Input Modules"
HOMEPAGE="https://code.google.com/p/imhangul/"
SRC_URI="https://imhangul.googlecode.com/files/${P}.tar.bz2"
-SLOT="3"
LICENSE="LGPL-2.1"
+SLOT="3"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
@@ -21,31 +20,32 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
src_prepare() {
+ default
+
# Drop DEPRECATED flags, bug #387825
sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' Makefile.am Makefile.in || die
}
src_configure() {
- econf --with-gtk-im-module-dir="${EPREFIX}/usr/$(get_libdir)/gtk-3.0/$(pkg-config gtk+-3.0 --variable=gtk_binary_version)/immodules" || die
+ econf --with-gtk-im-module-dir="${EPREFIX}/usr/$(get_libdir)/gtk-3.0/$(pkg-config gtk+-3.0 --variable=gtk_binary_version)/immodules"
}
src_install() {
- emake DESTDIR="${D}" install || die
-
- find "${ED}" -name "*.la" -type f -delete || die
+ default
+ dodoc imhangul.conf
insinto /etc/X11/xinit/xinput.d
- newins "${FILESDIR}/xinput-imhangul2" imhangul2.conf || die
- newins "${FILESDIR}/xinput-imhangul2y" imhangul2y.conf || die
- newins "${FILESDIR}/xinput-imhangul32" imhangul32.conf || die
- newins "${FILESDIR}/xinput-imhangul39" imhangul39.conf || die
- newins "${FILESDIR}/xinput-imhangul3f" imhangul3f.conf || die
- newins "${FILESDIR}/xinput-imhangul3s" imhangul3s.conf || die
- newins "${FILESDIR}/xinput-imhangul3y" imhangul3y.conf || die
- newins "${FILESDIR}/xinput-imhangulahn" imhangulahn.conf || die
- newins "${FILESDIR}/xinput-imhangulro" imhangulro.conf || die
-
- dodoc AUTHORS ChangeLog NEWS README TODO imhangul.conf || die
+ newins "${FILESDIR}/xinput-imhangul2" imhangul2.conf
+ newins "${FILESDIR}/xinput-imhangul2y" imhangul2y.conf
+ newins "${FILESDIR}/xinput-imhangul32" imhangul32.conf
+ newins "${FILESDIR}/xinput-imhangul39" imhangul39.conf
+ newins "${FILESDIR}/xinput-imhangul3f" imhangul3f.conf
+ newins "${FILESDIR}/xinput-imhangul3s" imhangul3s.conf
+ newins "${FILESDIR}/xinput-imhangul3y" imhangul3y.conf
+ newins "${FILESDIR}/xinput-imhangulahn" imhangulahn.conf
+ newins "${FILESDIR}/xinput-imhangulro" imhangulro.conf
+
+ find "${D}" -name '*.la' -delete || die
}
pkg_postinst() {