summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-22 16:05:11 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-22 16:32:24 +0200
commit0cdba49c2a095ba43667b418276a5743660bce3b (patch)
tree3fbf14a021771685537f2c59801c0031bfb51c01 /app-misc/openrgb
parentnet-libs/webkit-gtk: Depend on gui-libs/gtk[introspection?] (diff)
downloadgentoo-0cdba49c2a095ba43667b418276a5743660bce3b.tar.gz
gentoo-0cdba49c2a095ba43667b418276a5743660bce3b.tar.bz2
gentoo-0cdba49c2a095ba43667b418276a5743660bce3b.zip
app-misc/openrgb: check for at least 2GB of build space
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-misc/openrgb')
-rw-r--r--app-misc/openrgb/openrgb-0.8-r1.ebuild4
-rw-r--r--app-misc/openrgb/openrgb-0.9.ebuild4
-rw-r--r--app-misc/openrgb/openrgb-9999.ebuild4
3 files changed, 9 insertions, 3 deletions
diff --git a/app-misc/openrgb/openrgb-0.8-r1.ebuild b/app-misc/openrgb/openrgb-0.8-r1.ebuild
index d80c05c700e6..cb719d3d0b9a 100644
--- a/app-misc/openrgb/openrgb-0.8-r1.ebuild
+++ b/app-misc/openrgb/openrgb-0.8-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic qmake-utils udev xdg-utils
+inherit check-reqs flag-o-matic qmake-utils udev xdg-utils
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -47,6 +47,8 @@ PATCHES+=(
"${FILESDIR}"/OpenRGB-0.8-includes.patch
)
+CHECKREQS_DISK_BUILD="2G"
+
src_prepare() {
default
rm -r dependencies/{httplib,hidapi,libusb,mdns,json,mbedtls}* \
diff --git a/app-misc/openrgb/openrgb-0.9.ebuild b/app-misc/openrgb/openrgb-0.9.ebuild
index f67f687b0ada..9c15691b3b6b 100644
--- a/app-misc/openrgb/openrgb-0.9.ebuild
+++ b/app-misc/openrgb/openrgb-0.9.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic qmake-utils udev xdg-utils
+inherit check-reqs flag-o-matic qmake-utils udev xdg-utils
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -46,6 +46,8 @@ PATCHES+=(
"${FILESDIR}"/OpenRGB-0.9-udev-check.patch
)
+CHECKREQS_DISK_BUILD="2G"
+
src_prepare() {
default
rm -r dependencies/{httplib,hidapi,libusb,mdns,json,mbedtls}* \
diff --git a/app-misc/openrgb/openrgb-9999.ebuild b/app-misc/openrgb/openrgb-9999.ebuild
index 0b3ebc85f6c8..9fdf9377f299 100644
--- a/app-misc/openrgb/openrgb-9999.ebuild
+++ b/app-misc/openrgb/openrgb-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic qmake-utils udev xdg-utils
+inherit check-reqs flag-o-matic qmake-utils udev xdg-utils
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -46,6 +46,8 @@ PATCHES+=(
"${FILESDIR}"/OpenRGB-0.9-udev-check.patch
)
+CHECKREQS_DISK_BUILD="2G"
+
src_prepare() {
default
rm -r dependencies/{httplib,hidapi,libusb,mdns,json,mbedtls}* \