summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-10-18 18:54:59 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-10-18 18:54:59 -0700
commitd1e99a0901e1586a686010ed5cbe829bc74e5a0f (patch)
treeca38f6a99d82c21db249328df837694ef1033e4a /app-shells/loksh/loksh-6.4.ebuild
parentsys-cluster/poolmon: bump version (diff)
downloadgentoo-d1e99a0901e1586a686010ed5cbe829bc74e5a0f.tar.gz
gentoo-d1e99a0901e1586a686010ed5cbe829bc74e5a0f.tar.bz2
gentoo-d1e99a0901e1586a686010ed5cbe829bc74e5a0f.zip
app-shells/loksh: version bump to 6.4
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-shells/loksh/loksh-6.4.ebuild')
-rw-r--r--app-shells/loksh/loksh-6.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-shells/loksh/loksh-6.4.ebuild b/app-shells/loksh/loksh-6.4.ebuild
new file mode 100644
index 000000000000..ce9048c72511
--- /dev/null
+++ b/app-shells/loksh/loksh-6.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux port of OpenBSD's ksh"
+HOMEPAGE="https://github.com/dimkr/loksh"
+SRC_URI="https://github.com/dimkr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="!app-shells/ksh"
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install() {
+ emake \
+ BIN_DIR="${EROOT}/bin" \
+ DESTDIR="${D}" \
+ DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" \
+ install
+
+ dodoc NOTES
+}