summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-18 03:58:18 +0100
committerSam James <sam@gentoo.org>2022-08-18 04:09:57 +0100
commitbb2641741479ad64a0959c6eb3b80c4b6106e056 (patch)
tree7a4e1fb39296a20d58bea8c2019e4529b019f80a /app-text/lesspipe
parentdev-util/cmake: add 3.24.1 (diff)
downloadgentoo-bb2641741479ad64a0959c6eb3b80c4b6106e056.tar.gz
gentoo-bb2641741479ad64a0959c6eb3b80c4b6106e056.tar.bz2
gentoo-bb2641741479ad64a0959c6eb3b80c4b6106e056.zip
app-text/lesspipe: add 2.06
Bug: https://bugs.gentoo.org/865631 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/lesspipe')
-rw-r--r--app-text/lesspipe/Manifest1
-rw-r--r--app-text/lesspipe/lesspipe-2.06.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-text/lesspipe/Manifest b/app-text/lesspipe/Manifest
index ffb4af808828..8cfe33b34fa5 100644
--- a/app-text/lesspipe/Manifest
+++ b/app-text/lesspipe/Manifest
@@ -1 +1,2 @@
DIST lesspipe-2.05.tar.gz 167135 BLAKE2B 6f54a68a3857fcafa19148ba798d6ac49b2693e547e88a4a4fb6a178768d75ba8ae08e808a9e08aabfe903538bd401e3bd25e22ec240bf3a52365df729d87b9e SHA512 b4220b28fb609060735663067f5a738cae32d12e90efc397db3749e4dcfa7bfc063a4458c1f39b8a43be3b04effdc00a25c4feebd6e9a3b23f0064b879bbb698
+DIST lesspipe-2.06.tar.gz 168100 BLAKE2B a7447efa85cd422343f9dbb06001e85fa7b33c92db752f8248e4b4a0d9ecce4ef0241240d6993c5a71157c44da2f4ffc3efd41ac5e0a31e89ed5b80ac99f71fe SHA512 b2411c5e6b287fb67e1ea9b6d10377fe19b58e8c0f54587f825d1ee4c1a85f9a8ed3244a7cf339bcba960094e95821d9a56929951d862eb697f1d12fe55ef20d
diff --git a/app-text/lesspipe/lesspipe-2.06.ebuild b/app-text/lesspipe/lesspipe-2.06.ebuild
new file mode 100644
index 000000000000..b16b5f900cda
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-2.06.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="A preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://github.com/wofr06/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+# Please check again on bumps!
+# bug #734896
+RESTRICT="!test? ( test ) test"
+
+RDEPEND="dev-lang/perl"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ test? ( app-editors/vim )
+"
+
+src_configure() {
+ # Not an autoconf script.
+ ./configure --fixed || die
+}
+
+src_compile() {
+ # Nothing to build (avoids the "all" target)
+ :
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ einstalldocs
+
+ rm -r "${ED}"/etc/bashcompletion.d || die
+ newbashcomp less_completion less
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}