summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2022-04-14 09:22:18 -0400
committerCraig Andrews <candrews@gentoo.org>2022-04-14 09:23:01 -0400
commit657ee933df860906d72a5bcc646faead15f13b0d (patch)
tree31e2a35d573a7565a5b7e6704e5ef29ae4cc15b4 /dev-cpp/waylandpp
parentx11-terms/xfce4-terminal: Version bump, as requested by mgorny (diff)
downloadgentoo-657ee933df860906d72a5bcc646faead15f13b0d.tar.gz
gentoo-657ee933df860906d72a5bcc646faead15f13b0d.tar.bz2
gentoo-657ee933df860906d72a5bcc646faead15f13b0d.zip
dev-cpp/waylandpp: 0.2.10 version bump, EAPI=8
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-cpp/waylandpp')
-rw-r--r--dev-cpp/waylandpp/Manifest1
-rw-r--r--dev-cpp/waylandpp/waylandpp-0.2.10.ebuild41
-rw-r--r--dev-cpp/waylandpp/waylandpp-9999.ebuild2
3 files changed, 43 insertions, 1 deletions
diff --git a/dev-cpp/waylandpp/Manifest b/dev-cpp/waylandpp/Manifest
index b8e4e9b2f156..c0f7bf6468ee 100644
--- a/dev-cpp/waylandpp/Manifest
+++ b/dev-cpp/waylandpp/Manifest
@@ -1,2 +1,3 @@
+DIST waylandpp-0.2.10.tar.gz 187273 BLAKE2B bc6dd4503665d7fd04ac78e6db26aefe1ce1974bfa33ed751fe3714a3838af90340cef77c53cef95d519c423c639d93c2e15e1fc602301b254d56ca029e021be SHA512 02f0844e4003435d0e9edc4664b2843616aaeb46bd908b2301dc97945f285a57e62fba0d8693ce7a009bbb422aa23bf5261521a545f482e9f8c588e095340c99
DIST waylandpp-0.2.8.tar.gz 181950 BLAKE2B 186515308d2e17e39e61f953fcf43df6bcff45a965d6425ffb71f0314fc091d241a975d0e7a61e988091ae7491cab56e163b6bccc0a2584b79b5bd5a7f8573fd SHA512 bf1b8a9e69b87547fc65989b9eaff88a442d8b2f01f5446cef960000b093390b1e557536837fbf38bb6d9a4f93e3985ea34c3253f94925b0f571b4606c980832
DIST waylandpp-0.2.9.tar.gz 187141 BLAKE2B 0bf1bf62ccc792444d21941f15b675c9584822485c9869b66c40bcddbaac5716dcc25bf98e6110fc549f5f10c1197c9e5188c72b10cb878ba8e133a0e55b2db8 SHA512 abe683c236f3b082fb1bd64ce9cc93e4362040f41b31a42971a280fadc8a7ef06a47c6a02cb5201a3f4f864ccdc8a113a8d9a855ca99b42bf1fc322e2593648f
diff --git a/dev-cpp/waylandpp/waylandpp-0.2.10.ebuild b/dev-cpp/waylandpp/waylandpp-0.2.10.ebuild
new file mode 100644
index 000000000000..ed2592fab36d
--- /dev/null
+++ b/dev-cpp/waylandpp/waylandpp-0.2.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Wayland C++ bindings"
+HOMEPAGE="https://github.com/NilsBrause/waylandpp"
+
+LICENSE="MIT"
+IUSE="doc"
+SLOT="0/$(ver_cut 1-2)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/NilsBrause/waylandpp.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/NilsBrause/waylandpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+RDEPEND="
+ >=dev-libs/wayland-1.11.0
+ media-libs/mesa[wayland]
+ >=dev-libs/pugixml-1.9-r1
+"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ "
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-cpp/waylandpp/waylandpp-9999.ebuild b/dev-cpp/waylandpp/waylandpp-9999.ebuild
index ebd06ba3c06a..ed2592fab36d 100644
--- a/dev-cpp/waylandpp/waylandpp-9999.ebuild
+++ b/dev-cpp/waylandpp/waylandpp-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake