summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:07:43 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:39 +0100
commitd47dcf8b1c75b633379964cad0347be8c43a5abd (patch)
tree8485cf7b9049e5e3272cc52bbd4bd60273d88c00 /dev-haskell/hdbc-sqlite3
parentdev-haskell/hdbc-postgresql: Migrate to CABAL_CHDEPS (diff)
downloadgentoo-d47dcf8b1c75b633379964cad0347be8c43a5abd.tar.gz
gentoo-d47dcf8b1c75b633379964cad0347be8c43a5abd.tar.bz2
gentoo-d47dcf8b1c75b633379964cad0347be8c43a5abd.zip
dev-haskell/hdbc-sqlite3: add 2.3.3.1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/hdbc-sqlite3')
-rw-r--r--dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1.ebuild b/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1.ebuild
new file mode 100644
index 000000000000..c314661be79d
--- /dev/null
+++ b/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: -buildtests
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC-sqlite3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Sqlite v3 driver for HDBC"
+HOMEPAGE="https://github.com/hdbc/hdbc-sqlite3"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+splitbase"
+
+RDEPEND=">=dev-db/sqlite-3.0
+ >=dev-haskell/hdbc-2.3.0.0:2=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-buildtests \
+ $(cabal_flag splitbase splitbase)
+}