summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-launcher
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-launcher')
-rw-r--r--dev-java/commons-launcher/Manifest1
-rw-r--r--dev-java/commons-launcher/commons-launcher-1.1-r1.ebuild40
-rw-r--r--dev-java/commons-launcher/files/1.1-javadoc.patch24
-rw-r--r--dev-java/commons-launcher/metadata.xml5
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-java/commons-launcher/Manifest b/dev-java/commons-launcher/Manifest
new file mode 100644
index 000000000000..ce4e487a540e
--- /dev/null
+++ b/dev-java/commons-launcher/Manifest
@@ -0,0 +1 @@
+DIST commons-launcher-1.1-src.tar.gz 76558 SHA256 cc52afb97ea4a224d7d9c82e96c30725a290bd6cd44586e8a10c3d145bd3b83a SHA512 87f275ea1dbd08394c173da21023cb761175ff222fbe0ed6553fa6ca34eef775b57561227279216082556a8dd37593c9699a3e0c059bf3da98dbd2f1d3f58ddd WHIRLPOOL 0da4e77cb9166c806a4285b2efbbc5dadb79c26fd6254c4e2d6b818a19c5e675c52854538d0d73d30711ec6862cfa3cabfbc9b2bebdab2d650835cafece28fc0
diff --git a/dev-java/commons-launcher/commons-launcher-1.1-r1.ebuild b/dev-java/commons-launcher/commons-launcher-1.1-r1.ebuild
new file mode 100644
index 000000000000..8f2170e75fe2
--- /dev/null
+++ b/dev-java/commons-launcher/commons-launcher-1.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="examples doc source"
+
+inherit base java-pkg-2 java-ant-2
+
+DESCRIPTION="Commons-launcher eliminates the need for a batch or shell script to launch a Java class"
+HOMEPAGE="http://commons.apache.org/launcher/"
+SRC_URI="mirror://apache/jakarta/${PN/-//}/source/${P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4
+ dev-java/ant-core"
+
+S=${WORKDIR}/${PN}
+
+# https://issues.apache.org/jira/browse/LAUNCHER-7
+PATCHES=( "${FILESDIR}/1.1-javadoc.patch" )
+
+src_compile() {
+ java-ant_rewrite-classpath "${S}/build.xml"
+ EANT_GENTOO_CLASSPATH="ant-core" java-pkg-2_src_compile
+}
+
+# Standard commons build.xml but no tests actually implemented
+src_test() { :; }
+
+src_install() {
+ java-pkg_dojar dist/bin/*.jar || die "java-pkg_dojar died"
+ dodoc README.txt NOTICE.txt || die
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use examples && java-pkg_doexamples example
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-launcher/files/1.1-javadoc.patch b/dev-java/commons-launcher/files/1.1-javadoc.patch
new file mode 100644
index 000000000000..d83229a744eb
--- /dev/null
+++ b/dev-java/commons-launcher/files/1.1-javadoc.patch
@@ -0,0 +1,24 @@
+diff -ur src.old/java/org/apache/commons/launcher/types/ArgumentSet.java src/java/org/apache/commons/launcher/types/ArgumentSet.java
+--- src.old/java/org/apache/commons/launcher/types/ArgumentSet.java 2004-02-28 13:52:20.000000000 +0200
++++ src/java/org/apache/commons/launcher/types/ArgumentSet.java 2007-05-05 16:26:13.000000000 +0300
+@@ -18,7 +18,7 @@
+
+
+ /**
+- * A class that represents a set of nested <arg> elements.
++ * A class that represents a set of nested &lt;arg&gt; elements.
+ *
+ * @author Patrick Luby
+ */
+diff -ur src.old/java/org/apache/commons/launcher/types/ConditionalArgument.java src/java/org/apache/commons/launcher/types/ConditionalArgument.java
+--- src.old/java/org/apache/commons/launcher/types/ConditionalArgument.java 2004-02-28 14:43:31.000000000 +0200
++++ src/java/org/apache/commons/launcher/types/ConditionalArgument.java 2007-05-05 16:26:50.000000000 +0300
+@@ -24,7 +24,7 @@
+ import org.apache.tools.ant.types.Path;
+
+ /**
+- * A class that represents nested <arg> or <jvmarg> elements. This class
++ * A class that represents nested &lt;arg&gt; or &lt;jvmarg&gt; elements. This class
+ * provides the same functionality as the class that represents these same
+ * elements in a "java" task. In addition, this class supports conditional "if"
+ * and "unless" attributes.
diff --git a/dev-java/commons-launcher/metadata.xml b/dev-java/commons-launcher/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/commons-launcher/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>