summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/spice-jndikit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/spice-jndikit')
-rw-r--r--dev-java/spice-jndikit/Manifest1
-rw-r--r--dev-java/spice-jndikit/metadata.xml11
-rw-r--r--dev-java/spice-jndikit/spice-jndikit-1.2.ebuild45
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-java/spice-jndikit/Manifest b/dev-java/spice-jndikit/Manifest
new file mode 100644
index 000000000000..e402a50d2ffc
--- /dev/null
+++ b/dev-java/spice-jndikit/Manifest
@@ -0,0 +1 @@
+DIST spice-jndikit-1.2-src.tar.gz 23084 SHA256 3001e72223786e25a132ce8c41ff5e1d9fd8826e98122d5b73517aefd908e11a SHA512 bdb508eac32c8dac05be45553a6877e214dce4135c9ae96b95764254df4c0e57f2a7be3905301b096f140014e04e4fe6b517b7757553de26d73a513f7ff06244 WHIRLPOOL 62206bd937c9a7d9660ebda84782edcd08e331e48e389135a7b708999166ab122ce318aeac14386bbd091407c24a0096c14b72f42a073413b21a2bc65086cc3b
diff --git a/dev-java/spice-jndikit/metadata.xml b/dev-java/spice-jndikit/metadata.xml
new file mode 100644
index 000000000000..f43299979e05
--- /dev/null
+++ b/dev-java/spice-jndikit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription lang="en">
+ Spice JNDIKit: JNDI Kit is a toolkit designed to help with the
+ construction of JNDI providers. The toolkit also provides users
+ with ready made memory-based and RMI-based contexts.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-java/spice-jndikit/spice-jndikit-1.2.ebuild b/dev-java/spice-jndikit/spice-jndikit-1.2.ebuild
new file mode 100644
index 000000000000..280f0df73603
--- /dev/null
+++ b/dev-java/spice-jndikit/spice-jndikit-1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="JNDI Kit is a toolkit designed to help with the construction of JNDI providers"
+HOMEPAGE="http://spice.codehaus.org/"
+SRC_URI="http://dist.codehaus.org/spice/distributions/${P}-src.tar.gz"
+LICENSE="Spice-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND=">=virtual/jre-1.4"
+DEPEND="
+ >=virtual/jdk-1.4
+ test? ( dev-java/ant-junit )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ java-ant_ignore-system-classes
+ java-ant_rewrite-classpath
+}
+
+src_compile() {
+ java-pkg-2_src_compile
+ cd target/classes
+ rmic org.codehaus.spice.jndikit.rmi.server.RMINamingProviderImpl \
+ || die "rmic failed"
+}
+
+src_test() {
+ einfo "Tests need a network connection so they will fail without it"
+ ANT_TASKS="ant-junit" eant test -DJunit.present=true \
+ -Dgentoo.classpath="$(java-pkg_getjars --build-only junit)"
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}