summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-08-22 12:10:16 +0300
committerMart Raudsepp <leio@gentoo.org>2020-08-22 12:12:50 +0300
commit9e85721b8456f0806a3e515a7d5d40618ceb078c (patch)
tree6dfaa6ca9e1c382b2736b6862dafa666d51f39e5 /dev-libs/libgnome-games-support
parentdev-libs/libgnome-games-support: fix DEPEND (diff)
downloadgentoo-9e85721b8456f0806a3e515a7d5d40618ceb078c.tar.gz
gentoo-9e85721b8456f0806a3e515a7d5d40618ceb078c.tar.bz2
gentoo-9e85721b8456f0806a3e515a7d5d40618ceb078c.zip
dev-libs/libgnome-games-support: bump to 1.6.1
Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/libgnome-games-support')
-rw-r--r--dev-libs/libgnome-games-support/Manifest1
-rw-r--r--dev-libs/libgnome-games-support/libgnome-games-support-1.6.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/libgnome-games-support/Manifest b/dev-libs/libgnome-games-support/Manifest
index fbb9df05f60e..b2139af2ca10 100644
--- a/dev-libs/libgnome-games-support/Manifest
+++ b/dev-libs/libgnome-games-support/Manifest
@@ -1 +1,2 @@
DIST libgnome-games-support-1.4.4.tar.xz 336708 BLAKE2B ecd21376ce8d83a0a8c0f65992ba4d39d54b3b97d90df8adab0d5c5714d0c9841711a21dc611c94a8141313ff991c3a8787f7e27492c149a7f76e25d8a2fa8d6 SHA512 2b2c77210103610cb91554f870d634bc8d06f0886eef5166bf9909c1975a87d960005640d48e3e917f74c7553e3ae07d473ba06c6c5d6582313c50a390ec6168
+DIST libgnome-games-support-1.6.1.tar.xz 44012 BLAKE2B a7ef470f955d400a07d62452a7e2b0846e9ea6d01729bc6175963c474ea8a278a4903fd8bb1e0cdf9a19006f7306cb457901d20757573ba4fc35cf8d0397aa1c SHA512 a2f0c6faea4e10fcc06487a37147a3bbee9d41daeff2a323cf078bef45664166184f63e11fdba4afe6d2d1f8f2c0dba59274707d978c84b17b70305cb206b3a8
diff --git a/dev-libs/libgnome-games-support/libgnome-games-support-1.6.1.ebuild b/dev-libs/libgnome-games-support/libgnome-games-support-1.6.1.ebuild
new file mode 100644
index 000000000000..f47d5cd46c86
--- /dev/null
+++ b/dev-libs/libgnome-games-support/libgnome-games-support-1.6.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org meson vala xdg
+
+DESCRIPTION="Library for code common to Gnome games"
+HOMEPAGE="https://git.gnome.org/browse/libgnome-games-support/"
+
+LICENSE="LGPL-3+"
+SLOT="1/3"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+# glib dep in meson is 2.40, but vala is passed 2.44 target
+RDEPEND="
+ >=dev-libs/libgee-0.14.0:0.8=
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.19.2:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}