summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-12-04 10:16:16 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-12-04 10:16:48 +0100
commit449715905956b5cf2c7c353591b9f2c150761e16 (patch)
treee98b9b41780c96812cf01481360ee0b59d414c5a /dev-libs/libxmlb
parentdev-ruby/sassc-rails: fix gemspec generation (diff)
downloadgentoo-449715905956b5cf2c7c353591b9f2c150761e16.tar.gz
gentoo-449715905956b5cf2c7c353591b9f2c150761e16.tar.bz2
gentoo-449715905956b5cf2c7c353591b9f2c150761e16.zip
dev-libs/libxmlb: Bump to version 0.1.14
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libxmlb')
-rw-r--r--dev-libs/libxmlb/Manifest1
-rw-r--r--dev-libs/libxmlb/libxmlb-0.1.14.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libxmlb/Manifest b/dev-libs/libxmlb/Manifest
index da1045f309a0..99a52b428372 100644
--- a/dev-libs/libxmlb/Manifest
+++ b/dev-libs/libxmlb/Manifest
@@ -1,2 +1,3 @@
DIST libxmlb-0.1.12.tar.gz 91256 BLAKE2B b063bed9d7794b300ec40622c7fd0caac974b7f1be57b08ccb1864587b7bf47f892a39d1f4f0df226d3fe7ca03ffcec471a4f28afb8e64ae841d6898a337b60f SHA512 aebd9f41421bb0d78954038b3221bed879d296ec2d3061e7e7747980974e01081e51ea36d4e94545af5006b3dc4714d535aeea1943e42a7f1661ba1177979b31
DIST libxmlb-0.1.13.tar.gz 91597 BLAKE2B f5b1cffba36f25260df44b85109df22aca9f76a47a71c82b99504ce6f072b5b01c32aa26ae36ee37ff717a25dcbf094def8c3b65c7e53883aad726d919181db1 SHA512 ae2c043db0c3a9719c1527933e087825068f970bde28bc7b507a6535b51133d463b1dce6c8b02148a555bb28868ab563f7bb01e6324661dac92fab556c9a39b0
+DIST libxmlb-0.1.14.tar.gz 92388 BLAKE2B cf3057fadf87c866f456bb2eac773e056adba56e0912c249cd89acff2e9a722414876717c6b2065d836fee66032a3d55d9fd2a824ef1fe480604c36887b47c44 SHA512 906340212ce4a515bec81a1b7a5f04539712a48322d7fcff0992f82e5676cdf15c38b0340c28c9eed65a58321e3e17bac641f05bd403504c87599327ba6d4e49
diff --git a/dev-libs/libxmlb/libxmlb-0.1.14.ebuild b/dev-libs/libxmlb/libxmlb-0.1.14.ebuild
new file mode 100644
index 000000000000..4aa8384df186
--- /dev/null
+++ b/dev-libs/libxmlb/libxmlb-0.1.14.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="Library to help create and query binary XML blobs"
+HOMEPAGE="https://github.com/hughsie/libxmlb"
+SRC_URI="https://github.com/hughsie/libxmlb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc introspection stemmer test"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-apps/util-linux
+ stemmer? ( dev-libs/snowball-stemmer )
+"
+
+DEPEND="
+ ${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-libs/gobject-introspection )
+"
+
+BDEPEND="
+ >=dev-util/meson-0.47.0
+ virtual/pkgconfig
+ introspection? (
+ $(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+ )
+"
+
+python_check_deps() {
+ has_version -b "dev-python/setuptools[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use introspection && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dgtkdoc="$(usex doc true false)"
+ -Dintrospection="$(usex introspection true false)"
+ -Dstemmer="$(usex stemmer true false)"
+ -Dtests="$(usex test true false)"
+ )
+ meson_src_configure
+}