summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-16 14:55:53 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-16 14:56:22 +0100
commit0da42baa6d35192b7edcc12ef961502e56faf1ca (patch)
tree9128aa8d790b6151339eaec1204b69af25e559a8 /dev-python/OutputCheck
parentapp-emacs/org-mode: Stabilize 9.6 ALLARCHES, #891029 (diff)
downloadgentoo-0da42baa6d35192b7edcc12ef961502e56faf1ca.tar.gz
gentoo-0da42baa6d35192b7edcc12ef961502e56faf1ca.tar.bz2
gentoo-0da42baa6d35192b7edcc12ef961502e56faf1ca.zip
dev-python/OutputCheck: fix Driver
remove deprecated open 'U' option Closes: https://bugs.gentoo.org/891035 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python/OutputCheck')
-rw-r--r--dev-python/OutputCheck/OutputCheck-0.4.2-r1.ebuild (renamed from dev-python/OutputCheck/OutputCheck-0.4.2.ebuild)4
-rw-r--r--dev-python/OutputCheck/files/OutputCheck-0.4.2-Driver.patch11
2 files changed, 14 insertions, 1 deletions
diff --git a/dev-python/OutputCheck/OutputCheck-0.4.2.ebuild b/dev-python/OutputCheck/OutputCheck-0.4.2-r1.ebuild
index ca2d32009cbe..fc9ebef88ec2 100644
--- a/dev-python/OutputCheck/OutputCheck-0.4.2.ebuild
+++ b/dev-python/OutputCheck/OutputCheck-0.4.2-r1.ebuild
@@ -20,6 +20,8 @@ RESTRICT="!test? ( test )"
BDEPEND="test? ( dev-python/lit[${PYTHON_USEDEP}] )"
+PATCHES=( "${FILESDIR}"/${P}-Driver.patch )
+
src_prepare() {
distutils-r1_src_prepare
@@ -33,5 +35,5 @@ src_prepare() {
}
python_test() {
- lit "${S}"/tests || die "running test with ${EPYTHON} failed"
+ lit --verbose "${S}"/tests || die "running test with ${EPYTHON} failed"
}
diff --git a/dev-python/OutputCheck/files/OutputCheck-0.4.2-Driver.patch b/dev-python/OutputCheck/files/OutputCheck-0.4.2-Driver.patch
new file mode 100644
index 000000000000..9812bd728e0c
--- /dev/null
+++ b/dev-python/OutputCheck/files/OutputCheck-0.4.2-Driver.patch
@@ -0,0 +1,11 @@
+--- a/OutputCheck/Driver.py
++++ b/OutputCheck/Driver.py
+@@ -34,7 +34,7 @@ ExitCode = enum('SUCCESS',
+
+ def main(args):
+ parser = argparse.ArgumentParser(description=__doc__)
+- parser.add_argument('check_file', type=argparse.FileType('rU'), help='File containing check commands')
++ parser.add_argument('check_file', type=argparse.FileType('r'), help='File containing check commands')
+ parser.add_argument('--file-to-check=', type=argparse.FileType('r'), default='-', help='File to check (default %(default)s)')
+ parser.add_argument('--check-prefix=', default='CHECK', help='Prefix to use from check_file')
+ parser.add_argument("-l","--log-level",type=str, default="INFO", choices=['debug','info','warning','error'])