summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-14 16:52:53 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-14 17:33:41 +0200
commit601ff8e7c43f665f613c7130dfc67e5695f2667a (patch)
tree6805efbea55df9a961d6cb55afeba175b1cd1d91 /dev-python/OutputCheck
parentmail-filter/pyzor: Remove cumbersome REQUIRED_USE for tests (diff)
downloadgentoo-601ff8e7c43f665f613c7130dfc67e5695f2667a.tar.gz
gentoo-601ff8e7c43f665f613c7130dfc67e5695f2667a.tar.bz2
gentoo-601ff8e7c43f665f613c7130dfc67e5695f2667a.zip
dev-python/OutputCheck: enable py3.12 compat
Closes: https://bugs.gentoo.org/929474 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python/OutputCheck')
-rw-r--r--dev-python/OutputCheck/OutputCheck-0.4.2-r2.ebuild (renamed from dev-python/OutputCheck/OutputCheck-0.4.2-r1.ebuild)17
1 files changed, 8 insertions, 9 deletions
diff --git a/dev-python/OutputCheck/OutputCheck-0.4.2-r1.ebuild b/dev-python/OutputCheck/OutputCheck-0.4.2-r2.ebuild
index 814333b341ff..01ac4eea4db6 100644
--- a/dev-python/OutputCheck/OutputCheck-0.4.2-r1.ebuild
+++ b/dev-python/OutputCheck/OutputCheck-0.4.2-r2.ebuild
@@ -1,16 +1,17 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{9..12} )
inherit distutils-r1
DESCRIPTION="A tool for checking the output of console programs inspired by LLVM's FileCheck"
HOMEPAGE="https://github.com/stp/OutputCheck/"
-SRC_URI="https://github.com/stp/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+SRC_URI="https://github.com/stp/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -20,20 +21,18 @@ RESTRICT="!test? ( test )"
BDEPEND="test? ( dev-python/lit[${PYTHON_USEDEP}] )"
-PATCHES=( "${FILESDIR}"/${P}-Driver.patch )
+PATCHES=( "${FILESDIR}/${PN}-0.4.2-Driver.patch" )
src_prepare() {
distutils-r1_src_prepare
# Remove bad tests.
- rm "${S}"/tests/invalid-regex-syntax.smt2 ||
- die "failed to remove bad tests"
+ rm "${S}/tests/invalid-regex-syntax.smt2" || die "failed to remove bad tests"
# Create RELEASE-VERSION file.
- echo ${PV} > "${S}"/RELEASE-VERSION ||
- die "failed to write RELEASE-VERSION"
+ echo "${PV}" > "${S}/RELEASE-VERSION" || die "failed to write RELEASE-VERSION"
}
python_test() {
- lit --verbose "${S}"/tests || die "running test with ${EPYTHON} failed"
+ lit --verbose "${S}/tests" || die "running test with ${EPYTHON} failed"
}