summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-11 21:32:54 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-11 21:55:23 +0100
commit911079a7298f23b391824eb7a9bc146dce2d316c (patch)
tree8a75b79364b3466d99e74b894220d783fc2fc614 /dev-python/cliff
parentdev-python/urllib3: Bump to 1.26.1 (diff)
downloadgentoo-911079a7298f23b391824eb7a9bc146dce2d316c.tar.gz
gentoo-911079a7298f23b391824eb7a9bc146dce2d316c.tar.bz2
gentoo-911079a7298f23b391824eb7a9bc146dce2d316c.zip
dev-python/cliff: Bump to 3.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest1
-rw-r--r--dev-python/cliff/cliff-3.5.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index 2d357f1db111..6a03bc74cc1f 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1 +1,2 @@
DIST cliff-3.4.0.tar.gz 78990 BLAKE2B d7d8209e2fe24614cde6d3e113eb0dbbba981addef045fe318143e71f9a240188c0fb74e831d868b31b6dafb4289f7beabfbb5fe1dade1df196f670c53a55549 SHA512 d625588f4eed0aeee549b4a21e604f1cb886b8c10a12df7c546a5292223ec5bf9067352b4d326d5710673dab56eec47e2fb46c9c5d5df6e9fbf026d030bcde1c
+DIST cliff-3.5.0.tar.gz 82997 BLAKE2B f169770a0a956e6091e56eccda8d10906bee09bdb03b474f3b17837b3eda858f3afd21beae1d6945bcdabfa89fc1555d13d70ddd0454a10fe05bfb63c8de75e7 SHA512 215f22e5dd2c4c17bd0f19866189b6b247377a7d5bddeb4a07b7536af7545bd0440b5fb0a98474fc018e3b12f6695f60028c012f3e7eeb6498b20f2923939d08
diff --git a/dev-python/cliff/cliff-3.5.0.ebuild b/dev-python/cliff/cliff-3.5.0.ebuild
new file mode 100644
index 000000000000..5e6f9629a908
--- /dev/null
+++ b/dev-python/cliff/cliff-3.5.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+# TODO: revert to rdepend once this is merged
+# https://github.com/openstack/cliff/pull/3
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/openstack/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest