summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-11 22:08:37 +0000
committerSam James <sam@gentoo.org>2020-12-11 22:08:43 +0000
commita4887a3232f6e36dbf1607ec7ef6c393de08db8c (patch)
tree3e761b99c34205d0d1f38f59f59dfbdaddabe807 /dev-python/cryptography
parentdev-lang/python-exec: call internal _python_export to avoid warning (diff)
downloadgentoo-a4887a3232f6e36dbf1607ec7ef6c393de08db8c.tar.gz
gentoo-a4887a3232f6e36dbf1607ec7ef6c393de08db8c.tar.bz2
gentoo-a4887a3232f6e36dbf1607ec7ef6c393de08db8c.zip
dev-python/cryptography: bump to 3.3.1
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/cryptography')
-rw-r--r--dev-python/cryptography/Manifest2
-rw-r--r--dev-python/cryptography/cryptography-3.3.1.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/cryptography/Manifest b/dev-python/cryptography/Manifest
index bae04ba5930a..1914b61c708f 100644
--- a/dev-python/cryptography/Manifest
+++ b/dev-python/cryptography/Manifest
@@ -1,4 +1,6 @@
DIST cryptography-3.2.1.tar.gz 540994 BLAKE2B 667f09ac81423ecdc84c8646f0d02ee3a2955f55d35623e59c07696810a93c47332f7f8d877918eeeb6581d8e02bde3b70aae8e9d32be7ffbc8011e5e7e382a9 SHA512 e3f1806693c24aadc3ef0df374ce1845760e87ad7c243226b75e80820b50bdc0760e4bb5f6ce26d62a6d23736b3109f72cd30b52ae2a36b26ec5656ec96c6175
DIST cryptography-3.2.tar.gz 540815 BLAKE2B be4edd5d4cd9564e8622284ff9b1d3a7cc7d6e46cfa790d8e1cfa1ce389c5d628e39b056dc5cba3b94ab3fa45603df73a7b4ebd9d1c70fc88c457780f6616311 SHA512 0096e6408b5868cc0b5e6f67945e4200bb943a00ac803546048fa4d332f81af4a224b2d67b911ee8da1ad086120935d7d557fc70a739ecffb22f408ee9b8d09e
+DIST cryptography-3.3.1.tar.gz 539756 BLAKE2B a3eb52d756565ae83d9f2e06045be1d3439a2464b633a9a168101796a448d7c7531e8247862f7996d04500347d32dcebf6b1352e9c9f2e4f0d8008d4bbd000dc SHA512 62192fe0fd3bb8844ccc0056ab72a42b038db2a4ecb0928543c520b85e1de93066dab0d604acf23d37395d68172b9618f81c6022a59ec49725bc1862096d15d1
DIST cryptography_vectors-3.2.1.tar.gz 35168164 BLAKE2B 77af3be0dbd7393da7cd59600086041b78fe20339018a637fc1cf3600c7cd08cf2e565c79ccb47f4719a4b0f01cf2ab2db00c025805443b333dd7fdf3aa835a7 SHA512 44ff756a6ece9700f7657f8ba92417e95bf273cf500f1dab2141de5b2af6e61840d65c37b766abd752c76025ead1550bfc7b7340ce5774c75fd0bb8ac768cdd8
DIST cryptography_vectors-3.2.tar.gz 35168065 BLAKE2B ebd915eee9b91bd61445bcb442d3052972b1463132b8e63343832baa27c25566e22ca9f50c9d4ea73cb12185f9228144eaac4bf5cc68a3bd79f347fe2d021adc SHA512 bb0d00c8a66fd328ef38b0008519856a14d35b6fd634a6f67ea5530775d36538fbd326326c3f0cd962b1a008c21f2aded4d733f97bc12577679ed8be67b858bc
+DIST cryptography_vectors-3.3.1.tar.gz 35168171 BLAKE2B 72cf5d79773a728c16847e3e62f8ce444526c051d7562467446d3e59c66064568fdfcbfb1fd35419fd79079ff9a02a2f3a97f870f7adef6cc9a0fd23b4edf514 SHA512 a102535bd3cf72118106ca7268d5a9921738d41f81247940c550961d61cb0d1869095b7891c39e8dc15816f7d38230622846747b4b7a3f226f09306cf86220bd
diff --git a/dev-python/cryptography/cryptography-3.3.1.ebuild b/dev-python/cryptography/cryptography-3.3.1.ebuild
new file mode 100644
index 000000000000..bde114eb1121
--- /dev/null
+++ b/dev-python/cryptography/cryptography-3.3.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 multiprocessing
+
+VEC_P=cryptography_vectors-${PV}
+DESCRIPTION="Library providing cryptographic recipes and primitives"
+HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.org/project/cryptography/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ test? ( mirror://pypi/c/cryptography_vectors/${VEC_P}.tar.gz )"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="libressl idna"
+
+RDEPEND="
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ idna? ( >=dev-python/idna-2.1[${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]
+ ' 'python*')
+ "
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-1.11.4[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+DEPEND="
+ !libressl? ( >=dev-libs/openssl-1.0.2o-r6:0= )
+ libressl? ( >=dev-libs/libressl-2.9.1:0= )
+ "
+RDEPEND+=${DEPEND}
+
+DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
+
+src_prepare() {
+ default
+
+ # work around availability macros not supported in GCC (yet)
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ local darwinok=0
+ if [[ ${CHOST##*-darwin} -ge 16 ]] ; then
+ darwinok=1
+ fi
+ sed -i -e 's/__builtin_available(macOS 10\.12, \*)/'"${darwinok}"'/' \
+ src/_cffi_src/openssl/src/osrandom_engine.c || die
+ fi
+}
+
+python_test() {
+ local -x PYTHONPATH=${PYTHONPATH}:${WORKDIR}/${VEC_P}
+ pytest -vv -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}