summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-24 10:43:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-24 11:05:28 +0200
commit418477458fd3516dee7664c412608ff627285a28 (patch)
tree9ec479643816aa27bff0c0d95ce0932495359d3b /dev-python/dirty-equals
parentapp-xemacs/time: drop 1.17 (diff)
downloadgentoo-418477458fd3516dee7664c412608ff627285a28.tar.gz
gentoo-418477458fd3516dee7664c412608ff627285a28.tar.bz2
gentoo-418477458fd3516dee7664c412608ff627285a28.zip
dev-python/dirty-equals: Initial import, v0.3
New NIH test dependency for dev-python/watchfiles (which are continuation of dev-python/watchgod). Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dirty-equals')
-rw-r--r--dev-python/dirty-equals/Manifest1
-rw-r--r--dev-python/dirty-equals/dirty-equals-0.3.ebuild40
-rw-r--r--dev-python/dirty-equals/metadata.xml11
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/dirty-equals/Manifest b/dev-python/dirty-equals/Manifest
new file mode 100644
index 000000000000..1060596d4408
--- /dev/null
+++ b/dev-python/dirty-equals/Manifest
@@ -0,0 +1 @@
+DIST dirty-equals-0.3.gh.tar.gz 41665 BLAKE2B af46fb9b7f0e0eb6aba09e682db73b8eef4ab9d73523cf81fb510c093cbaaa18f87c9666094aa05031eda1c32374113bc59b404ab987472821aa21ef135c038d SHA512 b6bf9a241abdbf9f74dec6efa48a23d3a665910d964947b4583127930e940001600b410d524ab1ac48c75a030f1a37528a8dbce30e982f09f913b2b3afca77f1
diff --git a/dev-python/dirty-equals/dirty-equals-0.3.ebuild b/dev-python/dirty-equals/dirty-equals-0.3.ebuild
new file mode 100644
index 000000000000..f42198fbb2d9
--- /dev/null
+++ b/dev-python/dirty-equals/dirty-equals-0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Doing dirty (but extremely useful) things with equals"
+HOMEPAGE="
+ https://dirty-equals.helpmanual.io/
+ https://github.com/samuelcolvin/dirty-equals/
+ https://pypi.org/project/dirty-equals/
+"
+SRC_URI="
+ https://github.com/samuelcolvin/dirty-equals/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pytz-2021.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x TZ=UTC
+ epytest
+}
diff --git a/dev-python/dirty-equals/metadata.xml b/dev-python/dirty-equals/metadata.xml
new file mode 100644
index 000000000000..569f65cd7a6b
--- /dev/null
+++ b/dev-python/dirty-equals/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">samuelcolvin/dirty-equals</remote-id>
+ <remote-id type="pypi">dirty-equals</remote-id>
+ </upstream>
+</pkgmetadata>