summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-01-15 09:44:16 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-01-23 11:53:18 +0200
commit90a99f152920e41c3e45cd3d6e4bf3dc5cbe8ba0 (patch)
tree6fec468d4805823eea72f97f8ffe8bbb059baa07 /dev-python/humanfriendly
parentdev-python/capturer: Version bump 2.4 and add py3_7 (diff)
downloadgentoo-90a99f152920e41c3e45cd3d6e4bf3dc5cbe8ba0.tar.gz
gentoo-90a99f152920e41c3e45cd3d6e4bf3dc5cbe8ba0.tar.bz2
gentoo-90a99f152920e41c3e45cd3d6e4bf3dc5cbe8ba0.zip
dev-python/humanfriendly: Version bump 4.18 and add py3_7
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/humanfriendly')
-rw-r--r--dev-python/humanfriendly/Manifest1
-rw-r--r--dev-python/humanfriendly/humanfriendly-4.18.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/humanfriendly/Manifest b/dev-python/humanfriendly/Manifest
index ca1d68e9d3b1..696f85ba420a 100644
--- a/dev-python/humanfriendly/Manifest
+++ b/dev-python/humanfriendly/Manifest
@@ -1 +1,2 @@
DIST humanfriendly-4.17.tar.gz 344455 BLAKE2B 985ae142ea5378fcceb9f5f28773ac4dcaf0ea55ef1a7269fd1840a0b7119b54362aa93c330aa62e5424cc6f329e88717b45255c62b8e1d3f9ff5dd43a3c16c2 SHA512 a5786f28eaa0ff33919d9164ff30037fef5dbf60a31aece7679d1dddf3239f5a0d27209c710053cb0ac6779c1ef39102b1441fc620063283e90ef2ae11f8b621
+DIST humanfriendly-4.18.tar.gz 345853 BLAKE2B 9b03ea0679f787e216ee78efe8feb77f83562998813718845f4d21b7ce3f42cadff0e80b96f02da3cf6dc7f35cb0714f746940cf2ac0ec8e8981377989650c8a SHA512 01c7ee50d35154fe0b7ad39662ca6ff2dcd3e0f2a2eacc62f0184102c9db1c0fd99257273982aff56710b4e59024e8c20ee77ddd10c68e427c077ed4ca7e0022
diff --git a/dev-python/humanfriendly/humanfriendly-4.18.ebuild b/dev-python/humanfriendly/humanfriendly-4.18.ebuild
new file mode 100644
index 000000000000..f7b4b4a45d9e
--- /dev/null
+++ b/dev-python/humanfriendly/humanfriendly-4.18.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Human friendly output for text interfaces using Python"
+HOMEPAGE="https://pypi.org/project/humanfriendly
+ https://github.com/xolox/python-humanfriendly
+ https://humanfriendly.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="test? ( dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/coloredlogs[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_test() {
+ pytest -vv ${PN}/tests.py || die "Tests fail with ${EPYTHON}"
+}