summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-15 09:38:08 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-15 10:14:56 +0200
commitbc09138125aebb04ad3e6c4cecfff0277d7f3dbf (patch)
tree2a2dc7f6001ea2050ef21bd025ba91734e65505b /dev-python/legacy-cgi
parentdev-python/ujson: Remove old (diff)
downloadgentoo-bc09138125aebb04ad3e6c4cecfff0277d7f3dbf.tar.gz
gentoo-bc09138125aebb04ad3e6c4cecfff0277d7f3dbf.tar.bz2
gentoo-bc09138125aebb04ad3e6c4cecfff0277d7f3dbf.zip
dev-python/legacy-cgi: Add compat package for py3.13, v2.6
Add the compatibility `legacy-cgi` package that brings back `cgi` modules in Python 3.13. This is only meant as a stop-gap solution to fix dead packages relying on the module. As such, the package is deprecated immediately. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/legacy-cgi')
-rw-r--r--dev-python/legacy-cgi/Manifest1
-rw-r--r--dev-python/legacy-cgi/legacy-cgi-2.6.ebuild30
-rw-r--r--dev-python/legacy-cgi/metadata.xml12
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/legacy-cgi/Manifest b/dev-python/legacy-cgi/Manifest
new file mode 100644
index 000000000000..32ddc67cdb5a
--- /dev/null
+++ b/dev-python/legacy-cgi/Manifest
@@ -0,0 +1 @@
+DIST python-cgi-c6c8567a66f5ff8c5510755ca25a9bdd2756c4f6.gh.tar.gz 34964 BLAKE2B 0717bf9de721aef145443dd09475a4ed2d093bda0746512bc2074b2d7b90da37055662a47726240c9e7c07f0afca88639eb160d48289b0e9726e6638e1049b42 SHA512 0c0ca50a82a8fe76dd3eec56f75e408bbb035b16e726ba0156fd9360210068d63e7e3e60bd6f6793cef38276fc3c940d3195f7c0a9b1eea5056373358fbdb564
diff --git a/dev-python/legacy-cgi/legacy-cgi-2.6.ebuild b/dev-python/legacy-cgi/legacy-cgi-2.6.ebuild
new file mode 100644
index 000000000000..181f2547ee83
--- /dev/null
+++ b/dev-python/legacy-cgi/legacy-cgi-2.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_13 )
+
+inherit distutils-r1
+
+# this is 2.6 + tests
+EGIT_COMMIT=c6c8567a66f5ff8c5510755ca25a9bdd2756c4f6
+MY_P=python-cgi-${EGIT_COMMIT}
+DESCRIPTION="Fork of the standard library cgi and cgitb modules (deprecated)"
+HOMEPAGE="
+ https://github.com/jackrosenthal/python-cgi/
+ https://pypi.org/project/legacy-cgi/
+"
+# no tests in sdist
+SRC_URI="
+ https://github.com/jackrosenthal/python-cgi/archive/${EGIT_COMMIT}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
diff --git a/dev-python/legacy-cgi/metadata.xml b/dev-python/legacy-cgi/metadata.xml
new file mode 100644
index 000000000000..1de0f4062d0f
--- /dev/null
+++ b/dev-python/legacy-cgi/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">jackrosenthal/python-cgi</remote-id>
+ <remote-id type="pypi">legacy-cgi</remote-id>
+ </upstream>
+</pkgmetadata>