summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-03 09:30:32 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-03 10:31:58 +0300
commit7ce188ed97dfa74c4d2d900f0f3a6e909069c4ed (patch)
treeb15fc2f2ea21f29d4f1cc24de5f2c50f50aeaf33 /dev-python/logfury
parentdev-python/imread: enable py3.10, EAPI=8, fix docs gen (diff)
downloadgentoo-7ce188ed97dfa74c4d2d900f0f3a6e909069c4ed.tar.gz
gentoo-7ce188ed97dfa74c4d2d900f0f3a6e909069c4ed.tar.bz2
gentoo-7ce188ed97dfa74c4d2d900f0f3a6e909069c4ed.zip
dev-python/logfury: enable py3.10, EAPI=8, clean deps
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/logfury')
-rw-r--r--dev-python/logfury/logfury-0.1.2-r1.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/dev-python/logfury/logfury-0.1.2-r1.ebuild b/dev-python/logfury/logfury-0.1.2-r1.ebuild
index 5bb4e74c940e..7b049bb73c70 100644
--- a/dev-python/logfury/logfury-0.1.2-r1.ebuild
+++ b/dev-python/logfury/logfury-0.1.2-r1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Boilerplate library for logging method calls"
@@ -15,16 +14,15 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-PATCHES=(
- "${FILESDIR}/${P}-fix-requirements-remove-dev-tests.patch"
-)
-
RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
+BDEPEND="
test? (
dev-python/testfixtures[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
)"
-distutils_enable_tests setup.py
+PATCHES=(
+ "${FILESDIR}/${P}-fix-requirements-remove-dev-tests.patch"
+)
+
+distutils_enable_tests nose