summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/meld3
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/meld3')
-rw-r--r--dev-python/meld3/Manifest2
-rw-r--r--dev-python/meld3/meld3-1.0.0.ebuild27
-rw-r--r--dev-python/meld3/meld3-1.0.2.ebuild27
-rw-r--r--dev-python/meld3/metadata.xml9
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/meld3/Manifest b/dev-python/meld3/Manifest
new file mode 100644
index 000000000000..17ea1da8757a
--- /dev/null
+++ b/dev-python/meld3/Manifest
@@ -0,0 +1,2 @@
+DIST meld3-1.0.0.tar.gz 36232 SHA256 57b41eebbb5a82d4a928608962616442e239ec6d611fe6f46343e765e36f0b2b SHA512 17d90620b34ddecebcf1d08698149a598f1ac74f3a9c8c5fadcc2ea70d3d94c19ac3d662904f29a5093b3326131a2875940f3fa63a05f288de8e703cfee6e243 WHIRLPOOL f2b23c652757df094d3dc1e5b75b2f1e398c569201559e89cee098d1021b45227326667e510a442e2016d3c3651ce5c78e7e075720f58342f34df0bec6182565
+DIST meld3-1.0.2.tar.gz 36478 SHA256 f7b754a0fde7a4429b2ebe49409db240b5699385a572501bb0d5627d299f9558 SHA512 54fe6def7169fb4e3469cad8be58e56984026f27b3b8b2bfd6d53e2296e0c2a5bfb3e67d032ef75edd93306f4115a091930a7aae3573acecd3fed4acd6eeb544 WHIRLPOOL b4191073e3419dc845ec0f618553c1d7871ad67ec9b49578b5c37bc6d3fe28513375c19509f75be16698cedbc224ecbb9516f10a68da43fad2f82741a67b55fd
diff --git a/dev-python/meld3/meld3-1.0.0.ebuild b/dev-python/meld3/meld3-1.0.0.ebuild
new file mode 100644
index 000000000000..6b5f6f050b34
--- /dev/null
+++ b/dev-python/meld3/meld3-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="meld3 is an HTML/XML templating engine"
+HOMEPAGE="https://github.com/supervisor/meld3 http://pypi.python.org/pypi/meld3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+# tests use a local path.
+RESTRICT=test
+
+python_test() {
+ PYTHONPATH=. "${PYTHON}" ${PN}/test_${PN}.py || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/meld3/meld3-1.0.2.ebuild b/dev-python/meld3/meld3-1.0.2.ebuild
new file mode 100644
index 000000000000..f83fb0638ee6
--- /dev/null
+++ b/dev-python/meld3/meld3-1.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="meld3 is an HTML/XML templating engine"
+HOMEPAGE="https://github.com/supervisor/meld3 http://pypi.python.org/pypi/meld3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+# tests use a local path.
+RESTRICT=test
+
+python_test() {
+ PYTHONPATH=. "${PYTHON}" ${PN}/test_${PN}.py || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/meld3/metadata.xml b/dev-python/meld3/metadata.xml
new file mode 100644
index 000000000000..a0ae747bfbf6
--- /dev/null
+++ b/dev-python/meld3/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">meld3</remote-id>
+ <remote-id type="github">supervisor/meld3</remote-id>
+ </upstream>
+</pkgmetadata>