summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-31 08:42:26 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-31 08:52:41 +0100
commit1296d260a6c0eee9033fb4943360a05bb4ff1419 (patch)
tree67d778b2ba9a564008e6dafe43b32c3c615f45ce /dev-python/natsort
parentapp-accessibility/brltty: 6.4-r1 bump for several build fixes (diff)
downloadgentoo-1296d260a6c0eee9033fb4943360a05bb4ff1419.tar.gz
gentoo-1296d260a6c0eee9033fb4943360a05bb4ff1419.tar.bz2
gentoo-1296d260a6c0eee9033fb4943360a05bb4ff1419.zip
dev-python/natsort: Bump to 8.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/natsort')
-rw-r--r--dev-python/natsort/Manifest1
-rw-r--r--dev-python/natsort/natsort-8.1.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/natsort/Manifest b/dev-python/natsort/Manifest
index bec2d1e024c6..643131f681e1 100644
--- a/dev-python/natsort/Manifest
+++ b/dev-python/natsort/Manifest
@@ -1 +1,2 @@
DIST natsort-8.0.2.tar.gz 144912 BLAKE2B 0e5d83e6991ef1208b84cbf17e287f487a2a059d68274876977ae6f18f89492284bc166499a9518bfc2df19999e5593f386ce88beca94c23d8a050697c0b2a36 SHA512 fad31e1af1e1d4a33061b8b3e31d022f353f662d306136d05e0121a0531f33cf388467a40f91f51036f283ab8fbdefc1193d09f440052960ffdf733186b5fb27
+DIST natsort-8.1.0.tar.gz 145241 BLAKE2B dcf9ffdb58cfe4d0f7ca0ed74701c8137a87716831dc747c5fb68d187a93c1b7414fa3625c0ed385e727e97c36feb99e9ecc6a41dd3d9da342d357646b5aaf32 SHA512 a065899b124e6a6ee8560ce1882650e35f0c36ddfd3c56462820886b076cd8cdb0121825e30e298af576e07915cc5bc1e90fe3f0b1f7bfb89f816c00665baa22
diff --git a/dev-python/natsort/natsort-8.1.0.ebuild b/dev-python/natsort/natsort-8.1.0.ebuild
new file mode 100644
index 000000000000..37264f2f6599
--- /dev/null
+++ b/dev-python/natsort/natsort-8.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Natural sorting for Python"
+HOMEPAGE="https://pypi.org/project/natsort/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "sorting results that match most file browsers" "dev-python/pyicu"
+}