summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-16 11:58:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-16 13:27:26 +0200
commit9638ee70908b0e4e1c47998d6c47fc569d90fca0 (patch)
tree359a01e30c64d6851d43166cadc489a051bd5a80 /dev-python/psutil
parentdev-util/cargo-c: drop 0.9.16, 0.9.19 (diff)
downloadgentoo-9638ee70908b0e4e1c47998d6c47fc569d90fca0.tar.gz
gentoo-9638ee70908b0e4e1c47998d6c47fc569d90fca0.tar.bz2
gentoo-9638ee70908b0e4e1c47998d6c47fc569d90fca0.zip
dev-python/psutil: Bump to 5.9.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/psutil')
-rw-r--r--dev-python/psutil/Manifest2
-rw-r--r--dev-python/psutil/psutil-5.9.6.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/psutil/Manifest b/dev-python/psutil/Manifest
index 583286a3a254..c3a41d0d1196 100644
--- a/dev-python/psutil/Manifest
+++ b/dev-python/psutil/Manifest
@@ -1,2 +1,4 @@
DIST psutil-5.9.5-tests-r2.patch.xz 3776 BLAKE2B ba67e50d22c0ff05c3d31d5bcc1eb91fce59d2f933bf8693382aecdd9f20f2a4c4c3b759a3c03ff069b87241ab9f84905ad3b1c5f03eb5f3a2b12ed8ad967cf6 SHA512 6b20c6c78f772af767abee887a426b83129e3a13bb1cc13fa0111ad4dbd0a2a22ccc986af86b80d766bdf2a93a3a234327c6b56637b554164d9b0b0bac535fb9
DIST psutil-5.9.5.tar.gz 493489 BLAKE2B 3db8ce374d9d81dcddc08f03418675318c5e447f9a3347154d025537ba090811926ced822f83ff5fc9239665b091803a30d167465495049569c3c820f7fbb32d SHA512 2afe1bad5359aeac90378faaa609bab855dfcaa58519c939fdadb02e6e2c8157c77f961ac0f90d104626cef3429e1ea2f686e4dc4c9dccf975e3e73e9b08872c
+DIST psutil-5.9.6-tests.patch.xz 3780 BLAKE2B 002858235e7abf17c1426558cd9f8356cc7f21898f4488409e1cc4c6d76d6a017b8ca9e005e9973cfa890ff461691f5c0225e7c850ee4fde55cb1335d4ceca29 SHA512 1bd544ecd19ce7ff9a5e9f6e747b3f88ba44aabc289af87e3a1204028ebc26373dcdef9a9c5bd6ae13bc8d8d7d43ade41a8be2b14a02925afde1298ca0f9e6be
+DIST psutil-5.9.6.tar.gz 496866 BLAKE2B 65bd35ff6bcc2cfcb5f75f732a5a6955cb1fb5d889a5827aa2da27268716b10aa1dea23a87ee25aafc54e035927216501ecb98e56c655bfada57616a0d67e189 SHA512 0c363bf998868e450f014d5c5ddc2448986cafcd21309571e067be1c4b49d0e78259a5388094cbf32af7bca12865c5f3692480737f0a5225bbcfb895a9bf81f6
diff --git a/dev-python/psutil/psutil-5.9.6.ebuild b/dev-python/psutil/psutil-5.9.6.ebuild
new file mode 100644
index 000000000000..e28e2cda6093
--- /dev/null
+++ b/dev-python/psutil/psutil-5.9.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+TEST_PATCH=psutil-5.9.6-tests.patch
+DESCRIPTION="Retrieve information on running processes and system utilization"
+HOMEPAGE="
+ https://github.com/giampaolo/psutil/
+ https://pypi.org/project/psutil/
+"
+SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/${TEST_PATCH}.xz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${WORKDIR}/${TEST_PATCH}"
+)
+
+python_test() {
+ # Since we are running in an environment a bit similar to CI,
+ # let's skip the tests that are disabled for CI
+ local -x TRAVIS=1
+ local -x APPVEYOR=1
+ local -x GITHUB_ACTIONS=1
+ local -x GENTOO_TESTING=1
+ "${EPYTHON}" psutil/tests/runner.py ||
+ die "tests failed with ${EPYTHON}"
+}
+
+python_compile() {
+ # Force -j1 to avoid .o linking race conditions
+ local MAKEOPTS=-j1
+ distutils-r1_python_compile
+}