summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-10-21 20:39:37 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-10-21 20:47:11 +0200
commit5aa2eaa577c58785638e9f443bdc2762fb371992 (patch)
tree8ddf9db22a24bb1094abaf967ff6afce5f217996 /dev-python/pushbullet-py
parentwww-client/firefox-bin: synchronize with mail-client/thunderbird-bin (diff)
downloadgentoo-5aa2eaa577c58785638e9f443bdc2762fb371992.tar.gz
gentoo-5aa2eaa577c58785638e9f443bdc2762fb371992.tar.bz2
gentoo-5aa2eaa577c58785638e9f443bdc2762fb371992.zip
dev-python/pushbullet-py: bump to 0.12.0
And use distutils_enable_tests to simplify deps. Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/pushbullet-py')
-rw-r--r--dev-python/pushbullet-py/Manifest1
-rw-r--r--dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pushbullet-py/Manifest b/dev-python/pushbullet-py/Manifest
index 23ad44b78bd8..46d183f4e9e1 100644
--- a/dev-python/pushbullet-py/Manifest
+++ b/dev-python/pushbullet-py/Manifest
@@ -1 +1,2 @@
DIST pushbullet.py-0.11.0.tar.gz 21653 BLAKE2B a6c9b6f4958ce35b63ea4043d1d4f8691885bd0aa2927af541f2080a0b0b65a7df979a497967f3adceab8ad2382448a4c6a02d1184c9d72a18d91844eb970722 SHA512 b236f30b99e5bb79eff183529716c1c8f83cfd2526fdf50d86041eb6d3fcd6670d0c4dce407ae6e50aea0fa96d6a5527af980148f0c71ef758c480f972ad9659
+DIST pushbullet.py-0.12.0.tar.gz 23769 BLAKE2B 096c5995bee7dba65b7f385c2cbd70d839b22a07b26dd1ad9c1ef64244ba97e3c2f077c9eb0ca46a2ccd7df6a27e3ee3d4d55522986e832ca109d003e77fbad6 SHA512 5394fb8e8631ba00c610c36380e2c917231207ecd25bb4e2f1f0e44c232f4dd33b99ce5b1973467844b7f46f275ea812620e6549afd42915ee8fc13e1650f758
diff --git a/dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild b/dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild
new file mode 100644
index 000000000000..28a23a8aa3fa
--- /dev/null
+++ b/dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+DESCRIPTION="A simple python client for pushbullet.com"
+HOMEPAGE="https://github.com/randomchars/pushbullet.py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # skip tests which require network access
+ PUSHBULLET_API_KEY= pytest -vv \
+ -k "not (test_auth or test_decryption)" \
+ || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r example/.
+ fi
+ distutils-r1_python_install_all
+}