summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-13 06:15:45 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-13 06:44:46 +0200
commitf26884479ab72585ad5bc2f624a7a9a17fc29757 (patch)
tree8072f05c62ecad273d55b96f31efd1e8ab123115 /dev-python/pyfakefs
parentdev-python/csvkit: Bump to 2.0.1 (diff)
downloadgentoo-f26884479ab72585ad5bc2f624a7a9a17fc29757.tar.gz
gentoo-f26884479ab72585ad5bc2f624a7a9a17fc29757.tar.bz2
gentoo-f26884479ab72585ad5bc2f624a7a9a17fc29757.zip
dev-python/pyfakefs: Bump to 5.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyfakefs')
-rw-r--r--dev-python/pyfakefs/Manifest1
-rw-r--r--dev-python/pyfakefs/pyfakefs-5.6.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index b69fb60e375f..1b047122af84 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -1,3 +1,4 @@
DIST pyfakefs-5.3.5.gh.tar.gz 227359 BLAKE2B 635e41cb9892e1707555559769c01d5b575e44c5f1dd412acc05c3bed3b2dad2724ba32341b59cdecdfb658c94008e09396970349d8c1ffdcb90bf89ea82aca0 SHA512 342dc9cc0378af8cd8a9b0783fb6a1415207505ec8d4992f8fdd7e8d2bc4aada26d0803ed3b74d30b42a50dffb793c70acdeb3f28f199c0918783e1ea0a5e0d8
DIST pyfakefs-5.5.0.gh.tar.gz 239883 BLAKE2B cf9b91fbfbb77b012ec768ac2188ea5c611a271f50ded69cc92607d955b4dda8cacf7b0560da5a2b57f7a4aa6879fafb328357e5996d8c7c025f531530a04f4d SHA512 d9f05318f26ca9c26e0cca3c4fdf19dc3cf33bd21a6a87e1e4d8871b06eba9d8ba875301b001221ec9e0bd17c14f8aba3e61d3ec5b3c72587d28b7b5263e2a2c
+DIST pyfakefs-5.6.0.gh.tar.gz 242557 BLAKE2B d29e83d5ad6c7e313d28484754d2064d820856429c0e48e3b5851ecc1ae8cdfdc632f5855548229bc362b5323a7166b8d3776f2a2ccfb7472938362695a9f6f7 SHA512 7f3d8798088c66aaf57e238ee8f4693164508d23ff59fcde4a546af26da850a8c33cf0c552cb312ccfebbbbfc463db78ac80a356ce55634afc276124064ee210
DIST pyfakefs-9c19d6a55e6ebac98267713d571202e82b641279.gh.tar.gz 242645 BLAKE2B 175ebb18f15222152b12d0651cc378393f8a6d758d33355babca017a4fa4462610499466e0ba4ff429ac066880e1475fcb5c504cf085e067c87ceb878537ffb3 SHA512 b9c57128d057560882558b8d5ece24c98e377a6ed563e69d1e899106295f2fc43058265da092d34b9c00e886171f905acff851f78ce3e9c66ff4a9c0b1288581
diff --git a/dev-python/pyfakefs/pyfakefs-5.6.0.ebuild b/dev-python/pyfakefs/pyfakefs-5.6.0.ebuild
new file mode 100644
index 000000000000..9ebc980ca040
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-5.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/pytest-dev/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pyfakefs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=(
+ # test for regression with opentimelineio package
+ pyfakefs/pytest_tests/segfault_test.py
+ # test for regression with undefined package
+ pyfakefs/pytest_tests/pytest_fixture_test.py
+ )
+
+ if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ pyfakefs/pytest_tests/pytest_reload_pandas_test.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}