summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-10 09:56:56 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-10 09:57:28 +0200
commit62b2e4966d9bf12522a2d8f651e803e5cca3224d (patch)
treefd4eda494f854b988e1ff3bbfc979eb426e00692 /dev-python/pypresence/pypresence-4.3.0.ebuild
parentmail-client/mutt-wizard: Stabilize 3.3.1 x86, #910162 (diff)
downloadgentoo-62b2e4966d9bf12522a2d8f651e803e5cca3224d.tar.gz
gentoo-62b2e4966d9bf12522a2d8f651e803e5cca3224d.tar.bz2
gentoo-62b2e4966d9bf12522a2d8f651e803e5cca3224d.zip
dev-python/pypresence: add 4.3.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pypresence/pypresence-4.3.0.ebuild')
-rw-r--r--dev-python/pypresence/pypresence-4.3.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/pypresence/pypresence-4.3.0.ebuild b/dev-python/pypresence/pypresence-4.3.0.ebuild
new file mode 100644
index 000000000000..ceadf33a5aa0
--- /dev/null
+++ b/dev-python/pypresence/pypresence-4.3.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Complete Discord IPC and Rich Presence wrapper library in Python"
+HOMEPAGE="https://github.com/qwertyquerty/pypresence"
+SRC_URI="https://github.com/qwertyquerty/pypresence/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_sphinx docs/sphinx dev-python/alabaster