summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-29 04:46:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-29 04:46:53 +0200
commitfcc4d76ffa6919da2b797c5e6635c56625308248 (patch)
tree36b0349d7baddea417567a66d76eec52c75ff576 /dev-python/pytest-param-files
parentdev-python/aws-sam-translator: Bump to 1.72.0 (diff)
downloadgentoo-fcc4d76ffa6919da2b797c5e6635c56625308248.tar.gz
gentoo-fcc4d76ffa6919da2b797c5e6635c56625308248.tar.bz2
gentoo-fcc4d76ffa6919da2b797c5e6635c56625308248.zip
dev-python/pytest-param-files: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-param-files')
-rw-r--r--dev-python/pytest-param-files/Manifest1
-rw-r--r--dev-python/pytest-param-files/pytest-param-files-0.5.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pytest-param-files/Manifest b/dev-python/pytest-param-files/Manifest
index fa3e608d14cd..de95dc54aaee 100644
--- a/dev-python/pytest-param-files/Manifest
+++ b/dev-python/pytest-param-files/Manifest
@@ -1 +1,2 @@
DIST pytest-param-files-0.3.5.gh.tar.gz 7245 BLAKE2B 2a67c5ee30d6efb6b7ca7e3272c19c05dda460167cb1709693560ffe06b0ae39ae1b93fc5d6375f4e9cda21e3e02051424789afee55d201cfe070be8a05642ec SHA512 e80eddba2934fe5a6b68645cae243afa936ea3362a29d0b8a8ae4e11229ffb877f1ace9f41ac96d182d5787740fa76af8b106069feb95a7cab1ecc6f8d1088f9
+DIST pytest-param-files-0.5.0.gh.tar.gz 8563 BLAKE2B fa3907f3da7607caa3ab4933052ce70bc87bdf1b55983ef9660dbf0d6ae8a838d185be7f03f8ee5a1beb5771bb9f19f46fc012eea1eb7ca6331ba3c9626c72ca SHA512 cfff7ef20d453cf50a72e78d546a948d49c415c212ffba8e0ac4abe1da2decd9097930777b5aa182fb97c9c5c01e4b00bee25bd27f34c6f35a14ba7177d17a16
diff --git a/dev-python/pytest-param-files/pytest-param-files-0.5.0.ebuild b/dev-python/pytest-param-files/pytest-param-files-0.5.0.ebuild
new file mode 100644
index 000000000000..5982d88730fe
--- /dev/null
+++ b/dev-python/pytest-param-files/pytest-param-files-0.5.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest parametrize decorators from external files."
+HOMEPAGE="
+ https://github.com/chrisjsewell/pytest-param-files/
+ https://pypi.org/project/pytest_param_files/
+"
+SRC_URI="
+ https://github.com/chrisjsewell/pytest-param-files/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest