summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-25 09:35:08 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-25 09:58:49 +0200
commit635b25bda507c8367333110817e4b47011b303dd (patch)
tree39ad1e028e3def4e7907b738e5f500c417ad7fb3 /dev-python/pytest-services
parentdev-python/boto3: Bump to 1.15.5 (diff)
downloadgentoo-635b25bda507c8367333110817e4b47011b303dd.tar.gz
gentoo-635b25bda507c8367333110817e4b47011b303dd.tar.bz2
gentoo-635b25bda507c8367333110817e4b47011b303dd.zip
dev-python/pytest-services: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-services')
-rw-r--r--dev-python/pytest-services/Manifest1
-rw-r--r--dev-python/pytest-services/pytest-services-2.2.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pytest-services/Manifest b/dev-python/pytest-services/Manifest
index 5c9f267a1542..33203f5efd3e 100644
--- a/dev-python/pytest-services/Manifest
+++ b/dev-python/pytest-services/Manifest
@@ -1 +1,2 @@
DIST pytest-services-2.1.0.tar.gz 20552 BLAKE2B 6359c419591efed553e095e267c24f78f36b152f0eefe21d46742f7c15f05e92a9e86891f99762a3716fef5284b00d07d8d6eb825008dbbbf07e36dc62a7a6b4 SHA512 54a487546a2af7996acdbcd63bfc01626832aa41683617cdd345453cf6518afdf03cb8c2465e1f5d28c88b2cc801ffb0d9d4440582865f899e21fe42ab431ebc
+DIST pytest-services-2.2.0.tar.gz 20995 BLAKE2B a65455d89190d6b63854df7509124c8056c962640972f67210e3b3dbf2d669708e4edb124077cd32e7fe429e884372f4248396377b5d4879d9f7313c3ef7df46 SHA512 48430d6c107626a4e13a8eb16cf5cc3b2068e34869b8a4e3e615fd7a20f3644a028c911211f3de885ffd942cafd3946c313e76ddcf6199bedc9731f7b88c843a
diff --git a/dev-python/pytest-services/pytest-services-2.2.0.ebuild b/dev-python/pytest-services/pytest-services-2.2.0.ebuild
new file mode 100644
index 000000000000..4d08d2390cf1
--- /dev/null
+++ b/dev-python/pytest-services/pytest-services-2.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Collection of fixtures and utility functions to run service processes for pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-services"
+SRC_URI="https://github.com/pytest-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/zc-lockfile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pylibmc[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]
+ net-misc/memcached
+ !dev-python/pytest-salt
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/pytest-services-2.0.1-no-mysql.patch"
+ "${FILESDIR}/pytest-services-2.0.1-lockdir.patch"
+)
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ find "${D}" -name '*.pth' -delete || die
+}