summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-02 12:59:19 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-02 14:24:26 +0100
commit07610330d1e7166ad57be3c3d628bae183fc6404 (patch)
treeed88e7937cdc11538d147671761eb844dc4d871a /dev-python/pytest-sugar
parentdev-python/qiskit-terra: Bump to 0.46.0 (diff)
downloadgentoo-07610330d1e7166ad57be3c3d628bae183fc6404.tar.gz
gentoo-07610330d1e7166ad57be3c3d628bae183fc6404.tar.bz2
gentoo-07610330d1e7166ad57be3c3d628bae183fc6404.zip
dev-python/pytest-sugar: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-sugar')
-rw-r--r--dev-python/pytest-sugar/Manifest1
-rw-r--r--dev-python/pytest-sugar/pytest-sugar-1.0.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-sugar/Manifest b/dev-python/pytest-sugar/Manifest
index e11ef9d92410..76004c0a0723 100644
--- a/dev-python/pytest-sugar/Manifest
+++ b/dev-python/pytest-sugar/Manifest
@@ -1 +1,2 @@
DIST pytest-sugar-0.9.7.tar.gz 14874 BLAKE2B eb65d3261be10897b98f29704a8cd32102a91f7d3023651a6fc5c69e7d4f77c9ade1b3ca808047d0813503ceb416490126402f4751ac93fbdaadf9ddd1ef13c7 SHA512 7ab1a4f91bd252452ffd5b4fa636a1dffd4ffa5a19c839f2d00d0c69b885216144bb25e1a666bebb17be8112a397adfe04d5caa215edc98f64c20fefd43334cf
+DIST pytest-sugar-1.0.0.tar.gz 14992 BLAKE2B 75087685c88a2f5ff27cdebbc7600a23fc57c8ee556f57cf05ef3239b1a88866940f99635065fecf254e7fb7a96784edf1bfeaad1a9548077313c1bfd51146b5 SHA512 3976a77c76ae9a83a84753d426902650d0a63d686a84cdd25439c01ae444ae0a84c6095bf0ee5cfaf544e1cc69680001676a8dc4314d0f4d22c3021cb5b7c41d
diff --git a/dev-python/pytest-sugar/pytest-sugar-1.0.0.ebuild b/dev-python/pytest-sugar/pytest-sugar-1.0.0.ebuild
new file mode 100644
index 000000000000..d6f37b625e41
--- /dev/null
+++ b/dev-python/pytest-sugar/pytest-sugar-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Plugin that changes the default look and feel of pytest"
+HOMEPAGE="
+ https://github.com/Teemu/pytest-sugar/
+ https://pypi.org/project/pytest-sugar/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.2.0[${PYTHON_USEDEP}]
+ >=dev-python/termcolor-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest