summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-09 07:15:34 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-09 07:28:20 +0100
commit3a8c8416708f240b4e63b510e451edb7cd4980ed (patch)
treee91debe952bd69e6228e838ca3f96c5e454ccf3d /dev-python/quantities
parentdev-python/google-auth: Bump to 2.25.2 (diff)
downloadgentoo-3a8c8416708f240b4e63b510e451edb7cd4980ed.tar.gz
gentoo-3a8c8416708f240b4e63b510e451edb7cd4980ed.tar.bz2
gentoo-3a8c8416708f240b4e63b510e451edb7cd4980ed.zip
dev-python/quantities: Bump to 0.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/quantities')
-rw-r--r--dev-python/quantities/Manifest1
-rw-r--r--dev-python/quantities/quantities-0.15.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/quantities/Manifest b/dev-python/quantities/Manifest
index f2ffa4b2f7be..9234c2febf88 100644
--- a/dev-python/quantities/Manifest
+++ b/dev-python/quantities/Manifest
@@ -1 +1,2 @@
DIST python-quantities-0.14.1.gh.tar.gz 84275 BLAKE2B 7760a46f9f893a87badcbfd8aaad6a5598013b0cc835f17e0b788d3329be35702532fa17dc581ab0db4064292d6521d39d3ada7819c9a6c7b0e8a9b568d343dd SHA512 16c12110c2a705e4016d9575beb7f3322c3590cd12091a2710eca48fd6927b07b0d564ef93eb8af0b21688a0e86df1e60abb45625234abfaf1fa414e8b9fd110
+DIST python-quantities-0.15.0.gh.tar.gz 91327 BLAKE2B b75371e99b0f270d97cf6e9b80df1e7a0afa8ae8eb5d18750196e9b874737d58d3e3189ef9fdca4b312d24a19b406fe21f7eb304f0c1f11987873528190ca2e4 SHA512 987fb30d25a7b14e681d6eb963fc2cc68f954d017eca256739e897062249fce606adcb3224e3c8f0d371e49904caef7171a9a8ba4a7e60baa2fe063004846439
diff --git a/dev-python/quantities/quantities-0.15.0.ebuild b/dev-python/quantities/quantities-0.15.0.ebuild
new file mode 100644
index 000000000000..2ccb46a9debf
--- /dev/null
+++ b/dev-python/quantities/quantities-0.15.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="python-quantities-${PV}"
+DESCRIPTION="Support for physical quantities with units, based on numpy"
+HOMEPAGE="
+ https://github.com/python-quantities/python-quantities/
+ https://pypi.org/project/quantities/
+"
+SRC_URI="
+ https://github.com/python-quantities/python-quantities/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.20[$PYTHON_USEDEP]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ epytest --pyargs quantities.tests
+}