summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-23 07:30:29 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-23 08:16:22 +0200
commit531b293d3692eaa2bbdb50d7e49137174a4701b3 (patch)
tree1c30300e250826bc9bd749f0bc23e3eac1246149 /dev-python/rich
parentdev-python/orjson: Bump to 3.10.10 (diff)
downloadgentoo-531b293d3692eaa2bbdb50d7e49137174a4701b3.tar.gz
gentoo-531b293d3692eaa2bbdb50d7e49137174a4701b3.tar.bz2
gentoo-531b293d3692eaa2bbdb50d7e49137174a4701b3.zip
dev-python/rich: Bump to 13.9.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-13.9.3.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 9c5e873cc762..4009b1862fa2 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1 +1,2 @@
DIST rich-13.9.2.gh.tar.gz 15063908 BLAKE2B c83f736630a7bfbccda7d790476e7a9f518f2fa4e6bb3d4f5190bdeae784571875066c94bd8f4e01117b45a7eee83e9072bb7bb64ab5d5d8675aac5a63d5b0b5 SHA512 468e8f758c374264a77be154dde8908e04502cf8dfdc442dacfaebaaf9f1fbf634ae8dcbcefe42f7562183532a372aebebcdcb03c90031f619a8c5f2cd78f653
+DIST rich-13.9.3.gh.tar.gz 15064090 BLAKE2B 4ef76583ed13692b9f4a9714a68186fd06262e76d691f79cd256b4ab153052efd5fdf2320df797683ea1765cf063215a6b2d2614cd8040ebed0b89178cdcf2e0 SHA512 ca74d59e5df0476b482f60fac8d1f2e0810ffa61a10d410ff188c82548df3307405119f3b18992d96b01458b921ebcd61c99bf68dd808358395e9b04cf78579b
diff --git a/dev-python/rich/rich-13.9.3.ebuild b/dev-python/rich/rich-13.9.3.ebuild
new file mode 100644
index 000000000000..de21ed690f8d
--- /dev/null
+++ b/dev-python/rich/rich-13.9.3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
+HOMEPAGE="
+ https://github.com/Textualize/rich/
+ https://pypi.org/project/rich/
+"
+SRC_URI="
+ https://github.com/Textualize/rich/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/markdown-it-py-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.13.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/attrs-21.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ # TODO: segfault in recursion (PyQt6 interfering?)
+ tests/test_traceback.py::test_recursive
+ )
+ # version-specific output -- the usual deal
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # pypy3.10, to be more precise
+ tests/test_inspect.py::test_inspect_integer_with_methods_python310only
+ )
+ ;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ tests/test_inspect.py::test_inspect_builtin_function_except_python311
+ tests/test_inspect.py::test_inspect_integer_with_methods_python38_and_python39
+ tests/test_inspect.py::test_inspect_integer_with_methods_python310only
+ tests/test_inspect.py::test_inspect_integer_with_methods_python311
+ tests/test_pretty.py::test_pretty_dataclass
+ tests/test_pretty.py::test_reference_cycle_dataclass
+ tests/test_pretty.py::test_max_depth_dataclass
+ tests/test_pretty.py::test_attrs_broken
+ )
+ ;;
+ esac
+
+ local -x COLUMNS=80
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}